Japanese is Badly Broken - Part 1

Since Japanese is so badly broken now, I’ve decided to help by making a series, starting off with examples of the worst of it. The translations that are WILDLY off. This has been reported before, but after several weeks it has not shown no improvement. Hopefully these real world examples will help.

I’ve got pictures of Lingq’s translations on my iPad, along with what Google Translate gave me for an actual real, working translation.

ALL of these happened within the past couple days of reading. Imagine trying to read a foreign language like this.



In recent days, the errors in Japanese-English automatic translation have been continuous and frustrating. I don’t know if it’s because the novel I’m currently reading contains a lot of dialogue, but I can’t count how many times Lingq has translated a Japanese sentence as “The most important thing is…” which obviously had nothing to do with the original text.

Lots of other examples here:


Thanks for reporting, I asked our content team to look into it.

1 Like

@justfrozen Which exact lessons are these? Are they private imports, or shared lessons you found in the Library?

@nsprung private imports in my case , I posted more info in the other thread about this issue.

@nsprung yeah it’s a private import from an ebook

FWIW i imported 25 short books over the past year with zero issues. The last two have had constant issues including the issue I’ve showed in this post.

I really have two main issues and they are both translation related. The one I explained in this post, and the other one is that about one out of a dozen times the translation doesn’t load at all. Between these two translation bugs, reading is really painful. I’m lucky if I get half of my translations working. I’m barely getting by because after 25 short books I’ve gotten somewhat competent at reading, but that only lessens the pain a little, especially because it drains the fun out of the process.

Also, I have had long term language learning goals which keep me on it for hours per day, so it’s incredibly frustrating constantly running into these bugs. I’m not exaggerating either. What I pasted above was a tiny portion of what I ran into over those few days. I usually can’t go 5 sentences without a bad translation or one not loading.

I love this app, and I want to keep using it, and I’ve recommended it on language learning servers I’m on, despite it being pretty expensive. I’m really holding onto hope this will get fixed up like other things that have come and going over the past year.

@justfrozen @srdurden Unfortunately we are unable to reproduce this.

Does it ever happen with someone any user can access, like a news feed lesson? Or, would you be able to send the ebook(s) that have these poor translations?


I’m a bit frustrated to hear this. It gives me the feeling that no one on the team has read the thread where I’ve been reporting this issue for days, with examples and possible causes of the errors.

I generated a .TXT file with 10 lines of sentences that I have reported as failing inthis post:

I have imported it, and when translating, most of the time it produces nonsense translations. You can import it yourselves and compare the results with Google Translate.

The content of the txt file is:

」 二美子は思わず頭をあげて数に聞き返したが、数は少しほほえんでうなずいただけだった。

1 Like

@srdurden I was able to reproduce the bad translations, thank you. I’ll see what we can do about this.

@nsprung @zoran any news?

1 Like

@srdurden Please be patient, we are still working on this.

@nsprung @zoran I have discovered that different translations are generated depending on the location within the application where they are requested.

For instance, if I click ‘translate’ from the sentence reader, it sometimes translates it incorrectly:

However, if I edit the sentence:

…delete the translation and request the translation again (the blue button on the image from the sentence editing):

The generated translation is correct:

I have tried it every time where the translation was incorrect and it has always translated it correctly. Couldn’t it be applied to all the points where a translation can be requested?

Thank you for the additional information, we’ve passed it on to our QA team.

@nsprung any update about this issue? Thank you!,

@nsprung @zoran Since I discovered that the translation on the sentence editing screen is different, I’ve been conducting tests, and it’s clearly much better translated and also consistently translates the entire text (translations in sentence mode sometimes skip parts of the sentences). Not only does it translate well when there are Japanese brackets (「」), but the translations are much more accurate to the real meaning of the sentence.

@justfrozen I have also tested it in cases where the translation on the sentence view doesn’t load at all. While waiting the response, if you access sentence editing on iOS (as I explained in my previous post) and click the blue translation button, the translation loads immediately, and it’s probably even better than it would have been if it had worked correctly.

@nsprung please keep us updated, thank you!,

Hi srdurden,

We are still looking into this and it may take a bit more time to identify the issue here.

@nsprung @zoran any news?

@roosterburton Have you noticed that there are two endpoints in LingQ that generate translations in iOS, and one of them (the one with the blue icon) is much better than the other? Which one do you use in your extension? What parameters do they require, are they equivalent?

I’m not sure about this ‘blue icon’ I only have show translation button on IoS.

on IoS the ‘Show Translation’ button makes a Post request to lessons/*/sentences which I believe uses the ‘cleaned text’ to request a translation but that is not apparent.

When LingQing a phrase it sends the selected text directly to the V2 API v2/{lang}/translate

‘Show Translation Button’


‘Translate API’ (Not sure what is going on with the encoding, should be a ä in the request)

I also haven’t managed to figure out how to show the original lesson translation. (One generated on web)

@roosterburton The blue icon is in a different location within the application (in the phrase editing section); you have some screenshots in my previous messages. The endpoint has to be different because the translation result has nothing to do with the usual translation it performs (it’s way better).

I can see you have that download icon on your app, but it doesn’t appear on mine.