Updated Android App

All of you Android users will be glad to know that we just pushed a new version of iLingQ to the Android Market. We have added in playlists and all other functionality to match the iPhone app. Let us know how you like it!

I have just updated the app. Thanks a lot.

The updated app is working fine with a wi-fi connection.
However, the avatar is not displayed (even if “Disable Avatar” is NOT selected), but ok, this is the last of my problems… What really disappointed me was that it is still impossible to move the app to the phone SD card, in order to save space in the phone memory.

Good news, glad to hear it! I’ll report back after I get a chance to try out the new version.

@mikebond - That one’s on our list, and we hope to have it in the next release of the app.

Were any of long-lasting sync bugs fixed in this one?

Off the top of my head I don’t know. Try it out and let us know if you come across any issues! :slight_smile:

The main issue I am experiencing in this version, is that the app basically crushes after taping the Settings buttons. So, as for now, the only way I can switch the language is going to the Android’s app manager, clearing the app’s data, logging into LingQ once again and choosing the language in the “first start” menu. I guess, developers on Android Market have access to crash reports that users send, using the system, so, you now have a couple of mine.

My device is HTC Incredible S with Android 2.3.5 and HTC Sense 3.0.

@eugrus - Can you try reinstalling the app to see if that helps?

Ok. I’ve tried, but it didn’t help.

I just installed it on my wife’s galaxy tab 8.9 with Android 3.2 . It doesn’t even work. The old app was slow and buggy but at least i could sometimes get it to work a little bit =/.
This new update seems to fetch the lessons faster than the old one but as soon as i try to click any of the lessons It hangs there for 2-3 seconds and then crashes to the home screen.
No matter which lesson i pick. I also rebooted the tablet several times , as well as uninstalled and reinstalled the app 3 times and a combination of the 2.

This is the window i get after it crashes…


I appreciate the update. I sure hope you guys get it to work though. I’ll be waiting! I’m looking forward to being able to review lessons with a tablet.

Thanks for the report, keroro. We’ll be looking into these issues.

If anyone else notices any bugs in the app, please report them in this thread. The more info, the better :slight_smile: Thanks!

something i forgot to mentioned is… After I reinstalled the app to start it fresh. It asks for which language you want to load. I picked english because korean wasnt showing up on the list. After i picked english no lessons are loaded ( obviously because i have no lessons in that slot). When I settings i get the same issue as eugurs / same crash issue as i had above with the same msg…

I also had the crush problem at tapping on lesson or settings after upgrading from previous version.
After removing the app and installing it from zero it seems to work fine.

I was experiencing the crash issue when opening a lesson or clicking on the settings button but that stopped after I cleared the cache for the app. It seems to be working now but I don’t see any of my lingqs when I open a lesson. It is all in plain white text. The last version worked the same way for me in this regard… I’m supposed to be able to see my lingqs, correct?

I uninstalled and reinstalled again. I cleared the cache/app data . I rebooted my tablet. I relogged into ilingq. I picked japanese as language and it fetched the lessons no problem. I only had 5 lessons to fetch though… I can also open the lessons ( they are really short) No problem and do everything i should be able to do with the app…

HOWEVER I’m not studying japanese and clicking on Settings to change the language crashes the app unfortunately =(…

It seems that whenever I click on the “LingQs of the Day” tab, the view remains on the Lessons unless I have clicked on “Playlist” in between.
Also, I got an error message while I was connected with 3G, though it doesn’t reappear all the time like before.
The avatar does appear after re-installing the app, though not always.
Generally speaking, the reload of the single tabs seems to be quite slow, but I’ll do more testing.

The synchronization still doesn’t work either. As I connect to Wi-Fi after being offline, new cards that I work out sync, but not the ones I’ve done while being offline.
Every flashcard session (once there are no status 3 cards left) still ends with a crash as well.

Yesterday I did some listening with one of my lessons while I was on a slower, non-3G connection. Because of this, when I opened the android app I had to click the ‘work offline’ button. I had listened to this lesson previously so it was already downloaded to my phone. Later on in the day I opened the app while I was on a WiFi connection. Today I noticed that my stats for yesterday indicate that I listened to almost an hour of audio so something must be syncing. As for the flashcard problem eugrus pointed out, I don’t think I’ve studied any flashcards while in offline mode so I can’t speak for that. I’ll try that out tomorrow if I get a chance. I’ll be in an area where I don’t get any 3G connection.

By the way, for those of you that can open lessons do your lingqs show up or is it just plain white text? I’m just wondering if I’m the only one experiencing this issue.

I’m using an HTC MyTouch 4G Slide. Android version 2.3.4 and HTC Sense version 3.0.

So I’ve had some time to use the flashcard portion of the app now and it doesn’t seem to sync properly. This is the what I’ve seen happen a couple of times now:

I review flashcards for a lesson while online.
My stats are then updated. If I go to the website I can see that new words have been added to my known word total.
Later on I open the LingQ app in offline mode and listen to some audio.
I visit the website and see that my audio listening stats have been updated.
But… now I’ve got a negative number for my known words total for the day. I haven’t reviewed any flashcards since I last checked and when I did review I’ve only reviewed using the LingQ android app.

Any idea as to whats going on here?