Sound problems on iPad with the new version 5

First, is there a bug tracker for LingQ where I can report bugs? Forum seems a bit inefficient.

I really like the new version, it fixed a few annoyances for me. But at the moment there are two problems with audio on my iPad that drive me crazy.

If you tap on a word it plays the speech synthesis audio. While reading Japanese texts I usually tap all words to kind of train my brain for all the different kanji pronunciations. In the old version that worked flawlessly but in the new version there is often no sound. It seems that while one sound is playing I can’t start a new one. If I wait a second after the sound of one word played the sound of the next word always plays. But that slows me down immensly. In the old version I didn’t have that problem, that sound always played, no matter how fast I tapped on words after each other.

The other problem is that LingQ sometimes (but not always) controls the sound of other apps. I have a few books in LingQ where I also have the audiobook from Audible. So I use my iPad in splitscreen multitasking mode where LingQ fills two thirds of the screen in landscape mode and the Audible app fills the remaining third on the right side. I usually read a whole page and afterwards I listen to the audiobook with that segment. The worked flawlessly in the old version.
In the new version tapping on a word in LingQ does not only trigger the sound of the word in LingQ but also triggers “play” in the Audible app. So the audiobook is unpaused and starts playing. Even if I leave the splitscreen multitasking mode where the Audible app is running in the background it is still triggered. I can only kill the Audible app to stop the constantly unpausing of the audiobook.

I use an iPad Pro 10.5" from 2018 with iOS 15.1.

PS: I would also very much appreciate an option to turn of animations like the fade in of the dialogue window when tapping on a word. Looks nice the first few times but after a few hundred times it just annoys me and slows me down.

2 Likes

Totally agree!
So far I have submitted bugs via email. A bug tracker would allow users to directly interact with the developers, (thus freeing up Zoran’s valuable time). Also one would get confirmation, when a bug is fixed. In addition email isn’t really convenient when sharing screenshots etc.

Also I can reproduce the bugs you mention on my lowly iPad 6th gen. on iPadOS 15.2, app version 5.03.

Regarding the TTS, I think a good solution would be to create of queue. Thus, after tapping multiple words, the app would play them out in succession (of course this would have to be capped at like 5 items or so). Better than the other option of cutting off audio when requesting a new TTS item, I think the V. 4 app did this.

In fact, I have already expressed my discontentment with the overuse of animations in the new app on Dec 28th. This makes the app appear sluggish, while adding (imho) unnecessary eye candy.

1 Like

For Beta, there is a Beta forum and thread. Is the iOS version now technically “live” (non Beta)? I’ve lost track now. If it’s still Beta then you should be posting in the Beta forum and specific iOS thread. You might want to post the issue there anyway as the developers are following that and Mark.

Version 5.0 was released on December 27, 2021 on the App Store. See: ‎LingQ | Learn 42 Languages on the App Store
(click on version history)
I, for one, am not a beta user, that’s probably why I don’t see these forum threads. So I can’t report anything over there.

1 Like

Same for me. Just got the update from the app store. And I don’t see a Beta forum. Also wasn’t part of the beta testing, I’m just a normal user.

1 Like

Thanks for clarifying. I think I thought only the web had launched. They indicated they would obviously expect more questions/issues to pop up as it is released to the public, so hopefully it is more than just poor Zoran monitoring that forum.

I don’t even know whether the old version cut it off. Actually I’m not really tapping another word while the audio of the previous word is still playing but immediately afterwards. But there seems to be a window of maybe 500-1000ms where the next audio is still blocked. I guess there’s a bit of silence at the end of the audio file or it is something more technical like still using an audio object or something like that.

If I wait maybe two seconds it always works.

I guess I’m switching to the Android version temporary, I also have a color eink tablet and the app wasn’t yet updated there. It’s a bit sluggish because of the slow eink display but I still can go faster through it like with the problems in the current iOS version.

And I can play the audiobooks from my iPhone. Better than nothing, for Japanese the iPad app is nearly unusable for me at the moment. The problems kill every fun I had.

Thanks for this detailed bug report.
Regarding the text-to-speech audio playing, we are familiar with that problem. Let me try to explain it:

  1. The 4.0 app used apple’s built in audio. New app uses amazon for better quality.
  2. That means it has to download. We try to pre-fetch everything, but it still takes time.
  3. That also means there’s a small silence at the end as someone on this thread mentioned.
    That means that there can be a small delay, only first time you select a word/phrase, it then gets loaded and next time you select and play it, there won’t be any delay. I know it will be a bit annoying at beginning, but long term this will be much better, because the audio quality is better too.

We will also try to deal with the Audible issue you mentioned, it won’t be top priority now, but we will get to it.

1 Like

Thanks for the feedback!

Hm… I don’t really think that the problem is related to pre-fetching because I can recreate it if I just switch between two words that are side by side. Let’s say I have 今日 and は side by side. I touch 今日, the app plays “kyou”, immediately after the sound I touch は and the app should play “wa” but it doesn’t. If I wait a bit and touch then, it does.

Now I go back to 今日 and try it again and the は is not played again if I’m too fast. But as it already played it should be loaded as it already played two seconds ago.

I can also reverse it. I touch 今日, it plays “kyou”, I wait a bit, I touch は, it plays “wa” and I immediately touch 今日 again and it doesn’t play.

That would only be the case with prefetching if all downloaded audio is immediately deleted after use (which could be the case of course if you don’t use any local caching at all).

What would also be strange if it’s just a timing problem is that the audio never plays. I touch 今日, it plays “kyou”, I quickly touch は and it doesn’t play “wa”. Now I wait and wait and wait and the audio never comes. I have to touch it again.

I hope you can fix it, that problem makes me really HATE (and I don’t use that word light-hearted) the app because it doesn’t behave as expected and gives you constantly the feeling that something is broken. If it’s really prefetching you could just prefetch the next maybe five words. At the moment it seems to fetch only the next word because if I go quickly through the words I usually get the pattern “works - doesn’t work - works - doesn’t work” and so on.

Do you know the feeling when you have a remote control where the batteries are nearly empty and you often have to press multiple times or really hard so the buttons work? That’s how LingQ is feeling now for me all the time. It’s not a small annoyance, it turned using LingQ for me from being a joy to getting aggressive while using it.

I played around with the Audible problem and at least I can say that it doesn’t occur with every audio app. I tried using Spotify next to LingQ and LingQ doesn’t trigger “play” in Spotify. So the problem could be coming from Audible. They had an update two weeks ago.

That sounds frustrating.

I tried on ipad Mini (new). ONLY using LingQ and it seems I can tap on each word and get immediate sound…at least it sounds immediate to me, but I don’t typically do what you’re saying so I don’t know what I’d expect. I assume you are using auto text to speech? When you kill audible or the other “sound” apps does it work any better? Or is there still a delay? I did try on Japanese to see if there was something different about Japanese (it had worked fine on German for me) and didn’t see any difference. I chose a new story so it would have to “prefetch”.

Maybe the apps are using too much RAM when running altogether? No idea how to check that on ipad. Just throwing out ideas of what could be the problem.

Hopefully it’s something they can mimic and fix for you. If I get a chance I’ll try to see if I can do audible side by side to see if that does the same for me.

I had a look a bit further onto the bug with the not playing sound and I can say now that it has absolutely nothing to do with loading the audio file from the net.

I disabled wifi and 4g and checked the last sentence I had used. All audio still played so it had to be cached locally on the device as it was completely impossible to load it online. All the effects I had were still reproducible. If I touch two words quickly after each other the second audio won’t play. If I do it slowly it plays. Everything while the device was offline.

So it has nothing to do with loading the audio but has to be something different like using a second audio object while the first one is still in use or something like that.

The two effects aren’t connected. They are different bugs. Audible has nothing to do with the bug where words aren’t played, it happens always, no matter which apps are running.

I guess the problem doesn’t occur to many people as I’m tapping all the words very quickly after each other while reading. The reason is that Japanese has around 3000 characters and each character has around 1-4 pronunciations in average. And depending on which pronunciations meet they can create another pronunciation in combination.

That slows down your reading as a beginner or intermediate immensely. Because you rarely can’t be sure about the pronunciation. Similar to English were the writing is so inconsistent (e.g. the g in vegetable/vegetarian compared to vegan or the w in Greenwich/green witch). But in addition you have 3000 characters which makes it much harder.

The solution is to train that by reading hundreds of hours. LingQ helped me a lot with it. I read a word, say the pronunciation and then I touch the word and check whether I was right. Since I use LingQ I developed a quite high speed so I tap much more words after each other than most people, I guess.

That was absolutely no problem in the old versions of the app but now my workflow is broken. I could slow down, then it works again. But my goal is to speed up my reading. Going to a speed I had a year ago is frustrating as hell.

I also have that effect in Swedish but I don’t touch all words there. But if I have two yellow words side by side I do to check the pronunciation. And there the bug occurs also.

The key factor to reproduce it is speed. Tap two words fast after each other and the second one won’t play. Do it slowly and both will play.

RAM isn’t the problem. All audio files are already loaded as I checked (the bug still occurs offline). Also such an audio file is maybe 20 kilobytes. If iOS wouldn’t have that amount ready I would constantly have problems everywhere. Also it worked without any problems in the old app. So the hardware is definitely capable of that. An iPad Pro from 2018 is not the newest hardware but I still beats older laptops with e.g. a Core i3 cpu. It’s not a slow device.

1 Like

I only brought up the RAM since it is a new app and new technology they are using so potentially the app might be using more RAM than it was before (I don’t know that for sure).

I did try again on the ipad mini clicking quickly and sometimes not all that quickly and notice the problem today. In fact some words might not play at all…even after clicking other words and going back to them (still relatively quickly like 1 sec or less). Those words that get “stuck” don’t seem to work until you give it a few sec and then click it again.

Seems to be an issue on Android app too.

I think I read slow enough that even if I were doing this it might not be a problem for me.

I also tried in sentence mode and issue there as well.

Have you tried just switching to sentence mode and listening to the sentence in total? I know it’s nice to click on the occasional word for pronunciation for myself, but in general I like to hear the full sentence. Japanese, as you point out though, may be an entirely different animal.

I hope they can figure out how to speed it up for you!

1 Like

I checked the bug on an older iPad Pro and a newer iPhone too. Same problem. Doesn’t really seem to be related to the speed of the device as I have to wait the same amount of time until the sound works again.

Sentence mode doesn’t really help me as I want feedback for the word directly after reading it. After a longer sentence I guess I wouldn’t be sure anymore whether I read it correctly or not. I also listen to an Audible audiobook after I read the whole page so I don’t need sentence mode at all, haven’t tried it yet.

The audiobook material is much better, as the speech synthesis is not always the right pronunciation (I’d say around 1% is wrong, the spelled out version is then usually correct, they seem to use different software for the transcription and the speech synthesis). So if I think the speech synthesis is wrong I get feedback from the audiobook after I’ve read the page.

For me it’s mainly a real problem with Japanese. In Swedish it’s an annoyance as I encounter it at least two times a session too, usually if I have to yellow marked words side by side. But I could live with that. For Japanese it is such a huge problem for my daily immersion workflow that I’m now looking for alternatives that I could temporary use or completely switch to. Using LingQ since the update is just painful for me.

As I’m writing this I’m coming up with the idea of using the built-in accessibility features of iOS, maybe I can compensate the problem with it. I don’t expect LingQ to fix the bug as it seems to concern only very few people. Most people will touch only unknown words here and there and won’t ever experience that bug. If I’ll find a workaround, I’ll post it here.

1 Like

Another thing I discovered and what may lead to a fix for the bug:

If I touch a word the audio plays. If I touch the same word again while the audio is still playing or immediately afterwards where there still seems to be a bit silence until the audio is finished it won’t play again. So it’s the same like with different words. As long as audio is playing touch a word can’t play audio

But if touch the speaker symbol in the popup that appears after I touch a word I don’t have that problem. I even can touch the speaker in the middle of playing a word and the current audio is stopped and it plays again. The behaviour there is just like in the older version of the app.

So the bug doesn’t seem to have something to do with the audio alone but also how touching a word is handled.

I hope that helps fixing the bug.

I just updated to 5.04 and have attempted to capture the issue on video. Sometimes these issues can be difficult to convey using words alone. So I hope this can illustrate the problem. Please forgive the quality: https://drive.google.com/file/d/1vwsqju285ns3F2-Y6oKS2DyCokcQ6IcE/view?usp=sharing
In the video I’m alternating between two words, but only the first is played out. To be fair, it’s pretty close to working. If you slow down a little both play fine.

2 Likes

Thanks! That is exactly the problem what I meant.

While tapping words the finishing of an already playing audio file seems to be prioritized. If audio is already playing (even if its only 500ms of silence at the end) it doesn’t start the new audio of the second word but cancels it completely.

But tapping the speaker icon in the bubble/popup seems to prioritize the user input. You can tap it multiple times and if you tap it it will cancel all already playing sounds and plays again.

I prefer the last one because it does what the user expects. That was the behaviour in the old version of the app.

Thanks for the feedback here everyone. 5.0.8 should improve these issues.

2 Likes

I just checked 5.0.8 and it improved but isn’t fixed yet.

While going through my Swedish texts where I don’t touch every word, it didn’t have the problem anymore. In older version I had it occasionally.

In Japanese text where I touch nearly every word (to compare the kanji pronunciation in my head with the real one) quite fast the problem is reduced but I still have it very often. In older versions I had it with every 2nd word, now it is maybe every 4th or 5th word. If I add short artificial breaks between words (which unfortunately slows my down a lot) the problem is gone. In previous versions I had to add longer artificials breaks which was unbearable.

If I try to provoke the problem by touching other words while the audio of the previous word is not finished yet, the audio is still cancelled all the time. So the technical problem behind all that is still present.

It is no matter of loading the audio from the web, it still occurs if I switch between two words multiple times.

Thanks for the improvement! It’s not ideal yet but a bit less annoying.

Are you referring to the web voices or the local voices?
The new version reintroduces the Apple TTS, the Amazon voices seem unchanged. Unfortunately the change log on the Appstore didn’t mention this change. Maybe you missed this? (Settings → Voice → disable web voices)

My experience is that the local voices are indeed a lot more responsive, although rapidly tapping words is still a little janky. Especially the animations seem to hitch, at least on my device. (I’m still hoping for a “reduce motion” accessibility setting that would inhibit animations and just immediately display the pop-ups, see for example: https://support.discord.com/hc/en-us/articles/360040613412-Reduced-Motion-Setting)

1 Like