New Update for the Android App

We just uploaded a new version of iLingQ for Android to Google Play. Let us know what you think.

It addresses the following issues:

Flashcard synchronization
App closing usage: background processes
Lesson list (when returning to the list from a lesson, the same list needs to show)
Flashcard front/back (hints don’t show on Daily LingQs)
Offline lesson list (only one lesson shows)
Setting Sync Playlist Via 3G doesn’t work
playlist crashed, when add a Lesson without audio or play undownloaded Lesson.
iLingQ crashed in EditHintPhraseActivity
LessonView managing of Lesson/Playlist/DailylingQ
iLingQ crashed caused by: java.lang.IllegalStateException
switch to WiFi
save daily LingQ’s and Lesson LingQ’s together
save lesson and lesson of playlist together
add beta languages to language dialog
add: Lesson order like the LingQ-Site

It doesn’t look like the upload of the new version was successful. Google Play still has version 2.2.3 of iLingQ.


I also found only the 2.2.3 version.
I have also a few suggestion. To be really useful, the android version of lingq needs at least a pair issues:

the possibility to save offline more lessons. Otherwise I need to stay connected to a wifi or 3G (in Italy not ever possible without paying a lot).

for the above reason it would be helpful to have the possibiliy to download only the written lesson. This would give the possibility to “spare” Mb of traffic.

the possibility to hear at the word’s pronounce when reviewing the flash cards. I’ve created some of the lingq, not because I don’t understand its meaning, but because I’m not able to pronounce it correctly. So reviewing the flash cards without the sound is for me unhelpful.


It won’t let me update either

Sorry about that! It should be properly updated now.

Well, I have finally managed to get 1 lesson to upload (a French one) so I can see what the app is supposed to do. It looks very good. Unfortunately it times out when I try to upload my lesson list in Russian, Japanese, German or Chinese. Possibly the list of active lessons is too long, possibly a non-Latin character set slows things down. The LingQs of the day part often works.

@skyblueteapot - It only loads the most recent 30 lessons, so it shouldn’t be timing out because of the length of your lesson list. What kind of error message do you receive when this happens?

Well… I’ve tried out the new version for a bit and I don’t think the flashcard synchronization is fixed. I tried going through the flashcards for one of my lessons and it doesn’t appear to have updated anything. I completed all the flashcards for the lesson so nothing should be at status 1 for the lesson but that isn’t the case. Also, a few of the words would have been marked as known when I did this and my known words count for today is still at 0.

A couple of other things:

When reading a lesson, all the words that I’ve lingq’d but have marked with status 4 now show up with blue highlighting. The lesson is functionally the same - ie, I can only click on the yellow lingqs. I’m guessing the lessons are supposed to still look like they did before?

The above issues were on my phone, which is running Android 2.3.4. I also have a Samsung Galaxy Tab 2 running Android 4.0.4 and I can’t seem to log into the iLingQ app on that device. I always get an “Invalid Username/Password” error. I also couldn’t log in with the prior version of iLingQ on this device but instead of getting an error it would just crash after clicking to log in when using that version.

@cgreen0038 - Thanks for reporting these bugs. I’ve let our Android developer know and he’ll take a closer look into the synchronization and the highlighting

For the login issue, please follow the steps below so we can get a better idea of why this is actually happening:

  • install the app “aLogCat”
  • open the app “aLogCat” and clean the Log
  • switch to iLingQ
  • reproduce the issue in iLingQ
  • switch back to “aLogCat”
  • send the Log to support (at)

ok, i was able to download the updated app, and it opens my Spanish lessons, but now i have run into a whole new set of problems. In addition to the lesson text, i also get a bunch of garbage text too. For example: a style=‘text-decoration:none; background:ffffa0;color;black;’ href=‘14204558’.
It’s extremely disconcerting, it fills the whole page, and I cannot do my lessons this way.

@Alex: I get “network connection lost: retry / work offline”.

@alex - I just sent the requested log file.

Thanks for the log file. I’ll forward this over to our developer to help him figure the issue out.

@chumnutzly - Are you getting the same for any other languages? Also, is this the case in all languages? We’ll be sure to look into this too :slight_smile:

@skyblueteapot - I remember you were having this problem a few months ago as well, where you said it happened every time you opened the app. Are you still using the same device running Android 1.5?

its doing the same thing for Portuguese, and now it wont let me switch to another language from portuguese, i clicked the flag at the top of the screen and nothing, then went into the option and chose french, then it force closed. I don’t understand how the web system can be so great, but the Android app such a disaster, lol. Anyway, I’m sure it will be taken care of.

@chumnutzly - You may want to try reinstalling the app to see if that helps. If you continue to run into problems, just follow the steps above to send us a log file of the error, as this should help us better understand the issues.

@Alex: actually I think it’s Android 2.1. I shall have to check.

It’s certainly an old phone.

Still having problems after reinstall, So I sent the log to support

@cgreen0038 - Does your tablet have 3G, and if so, do you notice the same issue both on Wifi and 3G?

@alex - No, it just has WiFi.