New LingQ Mac problem

I hesitate to raise this problem because it may only be my computer. I can use the new LingQ on my wife’s Mac but on mine there are no hovering dictionary definitions. This is true in Firefox and Safari. Any ideas of what I can do to make it work on my own Mac?

A borked Java installation, perhaps?

Also, make sure you have all the latest system updates.

Another idea. In Safari, choose Safari > Preferences and then click the Advanced tab. Select the “Show Develop menu in menu bar” checkbox if it’s not already selected. You should now see the Develop menu between the Bookmarks and Window menus.

Make sure the Disable JavaScript menu item is not checked in the Develop menu.

Still, not sure why you are having the same problem in Firefox, which uses its own HTML parsing engine, as well as its own JavaScript interpreter.

You mean when you (inside a lesson) hover over a lingQ already created and there pops up the definition and hint you entered?

If it’s that I had not updated to the latest system updates in my other mac and it worked just fine.


Thanks for the suggestion. I went to Safari and checked show develop menu bar, but nothing showed up in my menu bar.

Since the old LingQ worked fine on my computer, and new LingQ works on my wife’s I think it is something on my Mac. I wonder if there is any setting that I can change.

I am stumped and wonder if any Mac users have any ideas. Is there something in the Finder/Applications area that I need to change?

Steve, you mean that you can’t create any lingQs because nothing popsup when you hover over a word?

I mean when you select a word and hover over it.

Go up, just beside the apple, Click on

There on “Web content” I have everything checked, he said maybe you had somehow disabled the Java, look up if it’s disabled there

Berta, Yes that is my problem, and I checked and Java is enabled. I have been using firefox, and the old lingq worked, and now it does not, although it works on my wife’s Mac. Mystery.

Yes and it’s a bigger mistery that both firefox and safari doesn’t work so that may tell us that it has something to do with your system. I’ll ask a friend, maybe she comes up with something else you can check up.

Thanks a lot Berta. I really do not know what can be causing the problem and if no one else has the problem I do not want to bother our programmers who have enough on their plate right now.

Incidentally, I notice that the hovering LingQ sub menu, the second line of the menu, does not appear on my computer but does on my wife’s. In other words, some setting in my Mac is preventing any hovering. Any advice out there? Many thanks.

Okay, let’s try to isolate the problem.

  1. Create a new user account
    • Launch System Preferences and click Accounts. Click the “+” button underneath the user list (Add a user account).
    • Choose Administrator or Standard from the New Account pop-up menu. Then type a name (for example, “Test”) and a short name (test) for the new account. For this test account, you don’t have to provide a password.
    • Click Create Account

  2. Log in to your new account
    • Click Login Options (bottom of the user list)
    • Select the checkbox labeled “Enable fast user switching” and click OK in the resulting warning sheet
    • Choose the new user from the Fast User Switching menu in the top right corner of the screen. You should now see the desktop of the new user you just created

  3. Test the new LingQ web site under the newly created account
    • Launch Safari and open Log in with your LingQ user name and password
    • Check for any differences from what you see under your primary account

  4. Log out and return to your primary account
    • From the Apple menu, choose Log Out (hold down the Option key do bypass the confirmation dialog)
    • Upon successful logout, you will be presented with a standard login screen. Enter your user name and password to return to your primary account

(If you wish to continue testing and want to go back and forth between your primary and test account, simply select the user name from the Fast User Switching menu. You will be returned to the selected user account.)

Report back to us if the problem persists under a new account.


many thanks for this. I just returned from dinner so I will not do it now, but a few questions

Create a new user account in what?

he means a new user account for your mac, so you can log into your mac with a new user account.

You can also try:
In Applications/Utilities/java

In the general tab you can change the version of the java you use.

I’ll tell you which ones I have at the top:
Java Applet Plugin—> J2SE 5.0 32-bit
Java Applications—> J2SE 5.0 32-bit

To change the preferred version use your mouse


Berta’s right. I mean a new user account on your computer. Mac OS is a multiuser environment. Several people can share the same machine, and each can have his own virtual machine custom tailored to his needs. Just follow my instructions above and you’re see what I mean.


Definitely something wrong with the site. I have Windows and use Firefox, on 1st of August all worked ok, I could hover my saved words, unknown words as well and the meaning popped up, from yesterday unknown words doesn’t pop up and I can’t see my saved words at all.

I tried test account Astamoore, but no difference. I did discover that in Safari, I can actually click on the highlighted words and open LingQ widget. But this turns out to be a function of using a different browser, the same happens in my main account.

I think there are problems with how my mouse interfaces with the computer.

  1. When I first open my computer there are certain functions that the mouse will not do, like highlighting a list to do a group action. I cannot copy files from iTunes folders etc. If I try the screen of what every I was working on starts to reduce in size and fade back on my monitor. This problem goes away after 15-20 minutes.

  2. After creating the Test account, when I switched back to my primary account my mouse would not work and I had to shut down (by turning off the power since the mouse would not work) and start again.

I think the mouse function is messed up.

Anyway I found out three things.

  1. I can have more than one account on my Mac
  2. I can click on highlighted words in LingQ in Safari
  3. The hovering definitions, the way it works on my wife’s computer, is for me, a much more pleasant experience. I think the greater sense of action or anticipation of action makes it more ludic, more pleasant, whereas the click on -click off seems more like work.