Netflix importer not working

I cant download any lessons as the imported doesn’t work. I get a message that say “no appropriate captions found”


Are you sure that the show you try to import does have subtitles available in your target language?

I’m having the same issue. I’ve tried with both Chrome and Firefox, neither works. The show is French and it definitely has French subtitles. I’ve enabled them and tried pressing the extension button while the show is playing and while it’s paused. No luck.

Same problem here, even after removing and reinstalling the extension.

Can you please post a link to that show? I’ll give it a try on my end. Thanks.

For me, it was that I tried today. The show has both “Flemish (CC)” and “Dutch” subtitles available, though the audio is labeled as “Flemish [original]” and from one of your other comments, I suspect that the plugin may not handle this. I tried selecting both versions of the subtitles before attempting to import and neither worked. If the audio-track language is being looked at for determining if a show can be imported to a certain language, I might suggest making “Flemish” an alias of “Dutch” since they’re really the same language with regional variation.

It was Call My Agent:

@chrisremo I just tried importing that with LingQ Chrome extension, under the French language slot and it worked without any problem. Are you sure that you have French subtitles enabled? Make sure not to confuse subtitles with audio.

That’s very strange, yes I definitely have French subtitles enabled and used the French language slot. I even made sure to have a French subtitle on-screen when I tried the import, just in case. I also did this on two completely different computers and had the same result. I’m glad to hear it’s possible for it to work at the moment but very frustrated that I can’t determine why it’s not working for me!

I’m also dealing with the same issue. I was able to import captions just fine this morning, and suddenly it’s not working with or without a vpn. Weird.

More info:
I’ve tried multiple Netflix shows in Dutch and none of them work. I tried importing both to a new playlist and to the quick-imports list. It failed on both Chrome 103 and Firefox 102 on Linux (Fedora 36). The Chrome plugin was reinstalled yesterday and the Firefox plugin installed for the first time today. Caching cannot be the culprit since this is the first time I’ve used Firefox for either Netflix or LingQ.

Edit: same result on Windows 10 with Chrome 103.

Looks like due to changes made by Netflix (and they didn’t push to everyone), only some users are affected by this change and have the issue. We are looking into it and we will try to have it solved and fixed asap.

Hi everyone, we just released a new extension version for Chrome. Please make sure to install the latest update and you will be able to import from Netflix again.

1 Like

I really appreciate the effort and response, but sadly this is still not working for me. I tried uninstalling and reinstalling the extension but it doesn’t seem to make any difference. Sometimes it takes a very long time “Loading” after I try importing, but eventually I get the same error message.

EDIT: Chrome still broken; Firefox working now

Same result here. In comparing 2.3.0 and 2.3.1, I see that initialization in worker.js has been wrapped in:
if (!document.getElementById(“LQNFXSUB”)) {

That does nothing to solve the problem that I pointed out in another thread.

@118 (previously 117, but now inside the if-block):
document.body.insertBefore(configElem, document.body.firstChild);

This still fails for the same reason, namely that document.body is null, resulting in “cannot read properties of null” in the console, and ultimately, a failure to create the div that’s used to store movie/subtitle data.

1 Like

Firefox looks to be fixed. Chrome is still broken.

1 Like

The notes above apply to Chrome. I just tried Firefox and that is indeed fixed.

Sorry to hear that. We will look into Chrome extension again.

I’m also dealing with the same issue. I was able to import captions just fine this morning, and suddenly it’s not working with or without Netflix Mod APK (Premium Unlocked) 8.72.1 Download. Weird.

Try Firefox. Chrome is still broken.