Ling says my lesson has 1 new word but it does not!

I’m having this problem too, but with more than just 1 word, and most lessons I start.

Me too.

I run into this frequently as well. I don’t think this is a new issue either as I’ve been running into variations of it for as long as I’ve been using LingQ. Sometimes the “move all words to known” button will still show up despite no new words being listed and clicking that will remove whatever unknown word isn’t being displayed to known. My gut feeling on this issue is that it is related to another issue where some LingQs wont display all the time. Particularly words that have had LingQs created for them but for whatever reason the system continues to treat them as new (blue) words.

Yeah! it is a fact that exist a long time.


Same. I just ignore it.
Edit: Wait! You read Prima #10 124 times?!!! I couldn’t stand reading something that much! :)~

@julz, yea. That’s why you are you and I am me :wink:

A bug is a bug is a bug! I have no choice but to ignore it until it is fixed.

I too have seen this bug in the past and have done the same as cgreen. However, in this case I am not presented with the option to move all new words to known. This is the first time I have come across this instance.

@pmilone - I noticed when I just came on earlier that I’ve got more affected lessons now on my lesson page too - even though the affected lessons say 0 LingQs & no option to move all new words to known - exactly as you said.

Harmless, but weird. I think my suddenly not being able to make LingQs the usual way is worse atm. Anyhow, good luck! Your Italian stats are impressive, btw. Ciao:)~ (my one word!)

That problem I see a long time ago. I just used to press F5 to refresh the screen when I`m near the end of the lesson to see the real situation with “new words” that remain.

And I have some notice about this site.
I like it, but I do not understand if there is a problem to make some test about sites working. It is not good that LingQs members do the tests.

@all - We have had some reports of this in the past, but have not successfully been able to reproduce the issue. Have any of you come across a way in which you ran replicate this issue? If you notice this issue with additional lessons, please let us know any additional information you can provide, such as:
-Did you study the lesson over multiple sessions?
-Were you using keyboard shortcuts or clicking with the mouse?
-Did you notice the New Words number go out of sync at any point during the lesson?

With your help hopefully we’ll be able to figure out what is causing this!

I too have noticed this from time-to-time. No big deal as far as i’m concerned.


@alex, typically I do study lessons over multiple sessions, I typically always click the mouse, I typically do not look at the new word number while studying a lesson.

I have also noticed (in this lesson) that the number of unknown lingQ’s indicated in the information window does not correlate with the actual number of unknown lingQ’s in the lesson. There are more in the lesson than on the info page.

@ alex - I worked it out! (it turns out I didn’t work it out, but I did find another error)

Here is a screencast where I reproduce the issue.

I start by importing some text from one of Vera’s German lessons that has no new words for me into a new lesson. However, I add three nonsense words to the lesson that I know will count as new words on my account. When I save and open the lesson, the lesson indeed has three new words, as it should. I then go back into the lesson editor page and remove those three nonsense words and reopen the lesson. You can see that the number of known words at the top of the dashboard is correct (i.e. 0), but in the other part of the dashboard, it says that I have 3 new words. This is the issue I reported recently on this thread.

I then go to the ‘My Lessons’ page and you can see that I am told that the lesson has three new words. It would seem that when a lesson is first imported, there is a word list made somewhere for use on the website to do calculations such as the number of new words in a lesson. However, when the lesson is edited, this list is not updated.

The lesson where ‘pmilone’ found one new word more than there should be must have had one more word when it was first uploaded than it does now. The person who shared it must have edited it.

@Collin, FYI, it is a private lesson that I myself uploaded and I have never edited it.


For my own curiosity I tried a couple of things…

  1. I created a new lesson with the same imported text. The new lesson showed no new words.
  2. I cut the text out of the lesson I’m having trouble with, then pasted back in the identical text from the original source. This did not fix the issue.

It appears that the problem is with the learn page not the lesson page.

Oh. Well in that case, I didn’t work it out, though what I reported is a separate bug that gives very similar results.

I have one more idea. Notice that the word ‘felicissimo’ is shown in the dashboard when you open the lesson. I have done a bit of testing, and it seems that when one opens a lesson, if there are no new words, the dashboard shows the list of LingQs, if there are multiple new words, the dashboard shows the list of new words, and when there is only one new word, the dashboard shows that new word. Maybe there is something up with that particular word. What if you deleted just that word from the lesson you are having trouble with (given the error I showed in my last post, this may appear not to work, even if that word is the bad apple)?

Do you still have the original source of the text? Maybe the text contained a hidden character in this one word that is being recognised by the part of the website and not another. I am just speculating now.


Now it’s fixed on the learn page when the course is opened but not on the learn page when the course is closed.

@ColinJohnstone - It looks like the New Words number is being cached (presumably to speed up loading). It probably makes sense to update this number whenever the lesson is edited in order to make sure it is up to date. That may then fix the issue noted above.

@pmilone - Thanks for the screencasts, it seems that the course is also caching the New Words number. We’ll take a closer look into what is going on here to make sure these numbers are accurate!

@ Alex

Shirley it’s a list of words being cached and not a new word number. However this does not appear to be the cause of pmilone’s problem. I have had this problem for a few texts too.