Lesson missing parts of text in new reader

This is the first problem I’ve encountered with the new reader. In this lesson: Login - LingQ

There is text missing in the new reader that appears both in the classic mode and in the print view. This missing text starts in the middle of one paragraph and ends in the middle of another. A snippet of the lesson text with the missing part enclosed in square brackets:

  •     Да, да… (смех) [Но отлично, отлично.
  •     О чем ты бы хотел сегодня поговорить?
  •     А, Евгений, 6 июня в России праздновали день рождения Александра Сергеевича Пушкина.] Поэтому давай обсудим этого интересного человека, да?.. (Лучше: Давай поговорим об этом интересном человеке)

The text is obviously in the database, but missing in the presentation. I haven’t carefully examined the full lesson to see if there are additional gaps in the text.

Yes, it strange.
I’ve checked my import - there are all sentences there.
And in the classic mode all sentences are present.
Why are some sentences lost in the new reader, I can’t understand as well.

Thanks for letting us know Khardy, I was able to fix this lessons. After I marked end of sentences properly on “Edit Lesson”, whole text show up properly now. Let us know if you notice similar issue on any other lesson.

I have the same problem.

See this snapshot.
Above is the presentation in the reader.
Below is the text in the print page (missing parts are outlined).

I cannot do a snapshot of the old reader as I am not allowed to use it (subscribed LingQ after launch of 4.0). :frowning:

Onother example of the new reader’s bug, see below.

Old reader: Login - LingQ

New reader: Login - LingQ

A related forum topic: https://www.lingq.com/forum/25/39815/

Can you post the link to that lesson? Thanks!

Thanks Ress, I’ll report this.

I imported that lesson. What did I wrong during import? It seems that the lesson import is broken! I am really unable to understand what is going on here. But it is not acceptable that a paying member can only use the new lesson view where some content is missing, while your lesson import is broken…

@Ress - This lesson seems to be working properly now.

If you share the imported lesson url, it will help us figure out what happened there. It normally has to do with some strange formatting or characters that have not been encountered before.

The underlided text is missing in the new reader.

Yes, it isn’t good.
It is almost one third of the article.
But why does it happen, if the base text is the same for both readers?

The solution may be this: “After I marked ‘end of sentence’ properly on “Edit Lesson”, whole text show up properly.”

The upload of lessons is broken, especially the splitting into sentences.

I’ve just sent my new lesson НАДО- НУЖНО (must or need) and it seems to be without omittin in both versions:

Seems to be quite a bit missing from the new reader in this Hebrew lesson as well Login - LingQ

Today I’ve sent another new my lesson О ПРЕДЛОЖНОМ ПАДЕЖЕ СУЩЕСТВИТЕЛЬНЫХ - and again it’s OK in both versions:

Now I try to return to my previous lesson - with splitting sentences, maybe I can do something.

I just went in and deleted some of the strange spacing at the beginning of the text and it seems to be showing fine for me now. Please check. I’m not sure if it was the spacing or line breaks but we will try to figure out why this type of thing is breaking the page. Sorry about this. In the meantime, if you have this problem Evgueny, you can try just deleting unnecessary spacing before and after paragraphs and sentences. It seems to fix things.

The way lessons are displayed now is different than before. The text has to be prepared on the server before it is sent to the browser so if there is an issue, the proper text isn’t sent to the browser and can’t be displayed. There are technological advantages to doing it this way I’m told and the same approach is also used for displaying the text on mobile. But, this means the original text needs to be more standardized than before. We are working to figure out how we can clean up original texts better so that we don’t have these kinds of problems.

Oh, my God!
I tried to edit this lesson ‘marking ends of the sentences properly’ - and I lost the most of the content of this artiicle in a new reader!..
I don’t know why because I put up two new lessons today, and they have no omits.
By the weay, where is the edit buttom in the new reader?
I dfidn’t find it.
I had to go to the classic view and from there I could go to ‘edit lesson’ - but without success!

Thanks, Mark! I tried to edit the text 45 minutes ago and did even worse.
But it seems to be OK now.
By the way, I can go to ‘edit lesson’ only from the classic view?
I ask because I didn’t find such an opportunity from the page with the new Reader.

You can edit from the menu at top left of the lesson text. The hamburger icon.