Importing Japanese book no longer respects paragraphs

Up until recently I’ve been able to import Japanese books without issues. However, recently when I import a book (mobi format) the paragraphs/line-breaks are completely removed–everything is one paragraph.

This makes it unenjoyable to read books I’ve imported into LingQ. Is this something that can be fixed?

Here are two example books I imported today where the line breaks were removed.

  1. Login - LingQ
  2. Login - LingQ

I have the same problem. A quick but rather annoying solution is to convert the ebook to a txt file and copy paste it into a new lesson… But I hope the ebook import will be fixed.

Thanks for reporting. We will look into the issue.

I have found the same issue with a Chinese ebook (in .epub format), yes.

We are working on the issue and we will have it fixed.

1 Like

I have the same issue with Chinese, nothing can import without becoming a huge block of text. same result on web and android app

This is still an issue for me…

Any updates on the status? Should we expect a fix soon or is the solution non-trivial?

We will push a fix soon. Thanks for your patience.

1 Like

Do you know if there’s been any progress on this? :slight_smile:

We are still working on it. I’ll post here when I get an update.

Is it fixed yet? This post must be 20 characters long.

I asked our team what is the status here and will post where I hear back.

Have you heard anything?

Ah, so this actually used to work. I’d never tried importing Japanese text before it broke, so I thought it was just another poorly implemented Lingq feature when it comes to Japanese, together with the horrendous (mis)parsing of words.

This should be fixed and working properly now. Do you still have issues?