Extension: Rooster HotKeys -> Modify keybindings for LingQ Reader

Great idea.
Please consider
-a key to show showing statistics
-always showing wordsread today
-a macro to go to the next sentence, show the translation and play the audio. Possibly mulipleorders. Possibly with a delay.

1 Like

Great idea, I’ll add this in the next patch.

I’ll have a look at how the data is created for this and get back to you

I’ll allow easy custom setup of automated keybinds in the premium version

2 Likes

Additional Edit:

Re-binded to “Shift + >” and seems to work more reliably than " Shift + :arrow_forward: " I’ll try it out for a bit and see. (I did a re-bind on the audio shortcuts that had that code for now 5 for 5 sec backward and 6 for 5 seconds forward and that worked. I tried the Shift + :arrow_forward: combo first and that didn’t work, so I went for the numbers instead.)


I’m still re-testing everything, but the short of it seems like just the " b " for “Next Blue LingQ” isn’t working, once I manually click on the next blue lingq the other LingQ actions appear to work.

Resetting the binds and uninstalling and reinstalling seemed to work(?) When I reinstalled Rooster Hotkeys to start testing all the shortcuts, the Shift + [arrow right/left] are working for me!!! :smiley:

1 Like

On my mac I often have to refresh the page because the shortcuts will stop working after extended use of lingq in one tab, regardless of roosters extension – the shortcuts always have been a bit flaky for me, no idea why. I’ve read that other users reported memory leaks on lingqs side, but I’m not sure if that could have to do anything with it. Can’t remember if I have the same issue on my linux.

2 Likes

I get serious memory leaks on Chrome if I leave LingQ open a while. That’s why I use Firefox.

@bbbblinq

ROOSTER HOTKEYS PATCH 1.27
→ Basic Tab system added


→ New bind (Toggle Stats Menu)
→ New bind (Show Words Read Today)* This auto updates every 30 seconds
image

Great to hear! It would be cool to know what keybinding configurations people came up with. Its a complicated problem now with duplicates and lots of unbound keys

2 Likes

Not sure why, but after changing the hotkeys once, whenever I revisit LingQ, the keys are reset and the tab dissappears.
Nothing seems to work except uninstalling and reinstalling the extension, resetting keys and changing them again, each time this happens.

Edit: Actually the extension just isn’t appearing at all now, I enabled permissions but still nothing. Not sure what’s interfering in this case.
Edit2: Seems some other web extensions like ‘leechblocker’ and adblocker aren’t compatible.

1 Like

@Vardan_Yervadian

The problem might be related to LingQs page navigation. They use a special navigation which doesn’t properly detect URL changes. You can try refresh the page when you are on the reader page it should show up

How could I use this fantastic ability on android phone?

1 Like

I’m not sure, does an android phone have a keyboard? Or do you mean for other extensions?

Some of these extensions are coming to Firefox for Android later this year

1 Like

Update 2: Legit resetting the binds, toggling the extension off and on again, and refreshing the page* often makes the shortcuts work again, this more likely a LingQ website/coding issue in my mind—not the Rooster Hotkeys extension.

P.S. I did the above again today and the go-to-next blue LingQ shortcut randomly worked again.

*I do this when the LingQ tab may have been open on a tab/idle too long.

P.P.S. Thanks for taking the time to reply @sarjag! It helped!! :smiley:

1 Like

The questions that keep me up at night. Why does this work on Chrome but die on Firefox and vice versa…?

hopefully we can find a solution where you don’t need to do that everytime!

1 Like

This page gives lifetime total words read. If you can pick up the first number, round it and show it, it would be useful.
https://www.lingq.com/api/languages/fr/stats/
{“Words of Reading”:81313.5551332149,“Hours of Listening”:1.10860720867366,“Known Words”:4979.0,“Hours of Speaking”:0,“Words of Writing”:0,“LingQs”:1802.0}

I’m trying " Rooster Reader for LINGQ" and I can’t see how to make it work - it does not appear.

image

2 quick ideas to add to the pile:

  1. Setting spacebar to a keyboard shortcut in the rebind menu displays a blank space, it could maybe be labelled with the word “spacebar” so you know the entry went in correctly and isn’t just an unset key. I started using spacebar for play sentence audio while in sentence view and noticed that it entered a blank space when I was binding it. The key works perfectly fine though so there’s no issue with the binding itself, just the way it’s represented in the gui overlay could maybe be made more clear.

  2. An assignable shortcut to toggle between sentence view and page view - the button in the bottom middle of the web reader.

The new toggle stats menu shortcut is surprisingly useful too, I didn’t know I wanted that until you put it in!

1 Like

ROOSTER HOTKEYS PATCH 1.28

→ Fixed!

→ Added!

You can thank @bbbblinq for that one

1 Like

Can we add "Increase Font Size" and “Reduce Font Size” as actions?

Seems like " - " for “Font Size” shrinks the font for LingQ, and “Shift +” enlarges it.

It Would be nice to keep " - " the same for shrinking the font and set the Increase Font Size shortcut to " = " as opposed to “Shift +”.

For me, I tend to increase my text font size over decreasing it. (The joys of vision impairment, lol—I wear glasses :eyeglasses: .)

1 Like

Something interesting I just noticed.

This is now what the Next blue LingQ shortcut looks like for me on Firefox:


Note: Before the latest update, this shortcut on the Firefox extension appeared like in the below image (i.e. b for next blue Lingq), and I was having more problems getting the shortcut to work.

This is what it looks like on Chrome:

[Stay with me on this.]

When I rebind the shortcut on Firefox to be the same as the Chrome image (initially how LingQ intended it), the shortcut doesn’t work in Firefox.

But if I set the Firefox extension to the shortcut shown in the Firefox image and use " b " as the shortcut (not Shift + B), the shortcut goes to the next blue LingQ as I want to. (Note: my caps lock is not on at any point). And Shift + B doesn’t seem to work.*

*This is also applicable to the Chrome extension.

Does any of this help or make sense? Anyway, I’m going to test this out for a while and see if this fixes the issue for me and allows me to avoid going through the process I detailed in one of my edits here.

P.S. Though all of this could be a weird coincidence that doesn’t help at all, :melting_face: :sweat_smile:

1 Like

Haha, I’m blown away by the speed you update these things… not even an hour later you have the update out! It works perfectly though, just tested it.

I noticed that the “All Controls” tab in the gui is missing the shortcut for “Toggle Sentence/Page View” but it’s available under the “Advanced Controls” tab. Just a heads up - obviously not a big deal!

Thanks for the update, this is awesome.

2 Likes