Extension: Rooster HotKeys -> Modify keybindings for LingQ Reader

You win @roosterburton, this is the best addon of all time hahaha. Excellent work across the board, the option to delete top and bottom definitions is so useful. Everything is working perfectly now, exactly what I was hoping for!


Great to hear @mhast

Also thanks very much for your donation. Appreciated!

1 Like

Hi, I’m not sure if it’s a problem just on my end, but rebinding “Translate sentence: Shift+t” won’t work, it updates in the edit window, but I still need to push Shift+t to show the translation.


Thanks for the report. It’s not working for me either. I’ll investigate.


It appears this issue is having the key bound twice. I tried it on ‘t’ it didn’t work because it is shared with 'tag. Then i tried with ‘n’ unbound and it worked.

1 Like

That’s strange, I tried bindind it to “.”, “5”, “8” and even “n” as you said, but sadly nothing changed.


I think the issue is to do with capital letters. I’ll push a fix right now. Let me know if it works.

It expects shift + T instead of shift + t.

edit: → Tested and functional.

→ Fix bindings for report/rewind/translate


It works now, thanks a lot!

Great. New patch for this coming soon with more binds and better menu headings



New bindings

"Open Popup: ": { key: " ", shift: true },
"Close Popup: ": “Escape”,
"Rewind Audio: ": { key: “<”, shift: true },
"Forward Audio: ": { key: “>”, shift: true },
"Open Editor: ": “”,
"Open Listen Mode: ": “”,

→ Added extra column and Column headers


→ Added 2 new binds (Change audio speed x1 and Change audio speed x3)

1 Like

Could you put in a hotkey-binding to toggle darkmode and between underlining/bold/making-invisible lingQ’s on the reader?

1 Like


→ toggle off the known word underline
→ toggle LingQed text bold,
→ toggle off LingQ colours
→ swap to dark mode

Is that right?

→ 3 new binds
→ Toggle lesson translation, open previous lesson, open next lesson


PATCH 1.23
→ Now only affects bindings on reader page. If having trouble on Listen/Editor/Library try refreshing page.

1 Like

→ toggle off the known word underline
→ toggle LingQed text bold,
→ toggle off LingQ colours
→ swap to dark mode

That’s right.

Also just wondering, what does ‘TTS on LingQCards’ actually mean?

1 Like

I’ll have a look what I can do for this on the next patch.

TTS TextToSpeech!

1 Like

Update: For some reason, custom hotkeys are periodically resetting whenever I change other settings, or change learning language on LingQ.

The hotkeys tab also vanishes after using it once, and when the page is refreshed, the hotkey bindings are reset again.



Thanks for the report, I’ll have a look

Edit: There is a problem with new patch 1.23, please use 1.22 Until i release the new patch

2nd Edit: Patch 1.24 is now live with the bug fix

3rd edit: Patch 1.25 is now live, which properly relimits the scope to reader page. (No more bugging out editor page)

→ New bind to remove colors / underlines from LingQs.
→ Extra bind to remove colors / underlines from LingQs and make them bold instead.
→ Now opens in Fullscreen @jpp025

1 Like

Hey @roosterburton,

With my smaller screen (13-inch) and no scrolling ability with the Hotkeys menu, I can’t really use it properly. Can we get a scroll going or resizing (from any point on the popup) going for this one?


Note: It’s pretty much just stuck like this.


P.S. The progression bar for the reader just stays on top of it, too, for some reason.

1 Like

I’m going to make a premium version with a proper menu and tabs etc!

And that sizing thing should be fixed. can scroll on the page now


Perfect! Thank you!!

Troubleshooting Guide

General Best Practices:

  • Don’t set two Keybindings to the same exact key combination (they may conflict and stop working).
  • Exit out of the LingQ Tab when you’re not using it (i.e., end of day/study session) to prevent shortcuts from going out.
  • Refresh the LingQ tab after long periods of inactivity.

Note: Below are just working lists that I came up with through trial and error. Still investigating when I can/have time!

Quick Reference Trouble Shooting When a Key Shortcut Isn’t Working:

Trouble Shooting Path 1:

  1. Check if the keybinding that isn’t working has the same key combinations as another keybinding.
  2. If one does, change one of the keybindings to a different key combination to prevent conflict.
  3. Refresh page and test new key binding.

Trouble Shooting Path 2:

  1. Reset Binds (wait until page refreshes)
  2. Toggle the extension off
  3. Refresh the page, Toggle the extension on again, and try the shortcut again (sometimes this works after that)

Trouble Shooting Path 3:

  1. Reset Binds (wait until page refreshes)
  2. Toggle the extension off
  3. Open the page (you want to use the keyboard shortcuts for) in a New Tab (make sure to close the tab that you were trying to get the shortcuts to work with—the tab/page may have been open too long).
  4. Toggle the extension on again.
  5. Refresh the New Tab from Step 3.
  6. Reset binds and rebind the shortcuts (with Rooster extension) to whatever you want it to be.
  7. Use/test the shortcut.
  8. Repeat steps 1-7 until the shortcuts work again if steps 1-7 don’t work the first time.

Note: It appears to be somewhat random (at least to me currently) when this 3rd method/troubleshooting path kicks in and works, so you may have to skip around and do any number of these combinations to get the shortcut to work—in the case I have detailed below. This is just what seems to be working for me. @roosterburton may come up with a fix/LingQ may figure their shortcuts out, but I just wanted to include this in case it helped anyone else! :smiley:

P.S. Trying a different key combination for shortcuts that are finicky might help, too.

Part of Original Post (not troubleshooting guide):

Edit 5: See this reply for the next update.

Edit 4: See this reply for an update.

Edit 2: Note: I noticed the next page shortcut default for LingQ: [hold down] Shift + right arrow worked once I uninstalled the Rooster HotKeys extension, but when I reinstalled it, and tried to do the same default shortcut it stopped working.

Edit: Yeah, seems like the LingQ Keyboard shortcuts are flaky in general, so there’s not much to be done until LingQ figures this out, so I’ll uninstall for now and try to mess around with LingQ’s shortcuts and report them to their support team, and revisit this extension. (Looks great overall! Once it can work for me, I would love to reset a few—handful—bindings I would use. Note: If you don’t struggle with LingQ’s shortcut keys issues, this won’t apply to you.)

I’m not sure why it’s not working for me, but not even the original shortcut from the LingQs side works for me when it comes to moving to the next page. Are LingQs bindings (and maybe even these bindings) more friendly to non-mac users?

I tried setting the next page hotkey to the command (a.k.a. “meta” ?) + arrow right (:arrow_forward: ), but it’s just doing the move to the next LingQ thing for me.

Additionally, in this case, the arrow right (by itself) also moves me to the next LingQ (which is what I want it to do anyway, but not on the command/“meta” + arrow right shortcut).

So it’s like it doesn’t even register that I’m pressing command/“meta” at all.

Edit: I can right/ left (:arrow_forward: /:arrow_backward: ) arrow in either direction until it moves onto the next page—not very practical—though.

Anyone with a MacOS experience this? (either on LingQ—without the Rooster Extension—or with the Rooster extension)?

Also, the default keybinding for Translating (Shift + T) triggers my Firefox browser to open up a new tab, so it’s extra weird.

Any thoughts @roosterburton? (I understand this may be out of your scope here, just wondering.)

1 Like

Not sure about this @jpp025. I just rebound that key to Ctrl+v and it worked well.

Try press Reset binds before making any changes.

Not sure about this either. I obviously haven’t tested the Meta key but the code looks right.

Shift+T is just the translate sentence toggle, you need to be in sentence view for it to work. There is a different bind to trigger the lesson translation.

Not sure why it triggers new tab either. I would need a MAC to properly investigate.

Do any of the keys work? Is it just these keys that are broken for MAC?


Updated to 1.26 and everything is working great over here, using these custom binds every day and it’s making such a difference. Thanks again for all the work on this @roosterburton!

1 Like