Extension: Rooster HotKeys -> Modify keybindings for LingQ Reader

Troubleshooting Guide

General Best Practices:

  • Don’t set two Keybindings to the same exact key combination (they may conflict and stop working).
  • Exit out of the LingQ Tab when you’re not using it (i.e., end of day/study session) to prevent shortcuts from going out.
  • Refresh the LingQ tab after long periods of inactivity.

Note: Below are just working lists that I came up with through trial and error. Still investigating when I can/have time!

Quick Reference Trouble Shooting When a Key Shortcut Isn’t Working:

Trouble Shooting Path 1:

  1. Check if the keybinding that isn’t working has the same key combinations as another keybinding.
  2. If one does, change one of the keybindings to a different key combination to prevent conflict.
  3. Refresh page and test new key binding.

Trouble Shooting Path 2:

  1. Reset Binds (wait until page refreshes)
  2. Toggle the extension off
  3. Refresh the page, Toggle the extension on again, and try the shortcut again (sometimes this works after that)

Trouble Shooting Path 3:

  1. Reset Binds (wait until page refreshes)
  2. Toggle the extension off
  3. Open the page (you want to use the keyboard shortcuts for) in a New Tab (make sure to close the tab that you were trying to get the shortcuts to work with—the tab/page may have been open too long).
  4. Toggle the extension on again.
  5. Refresh the New Tab from Step 3.
  6. Reset binds and rebind the shortcuts (with Rooster extension) to whatever you want it to be.
  7. Use/test the shortcut.
  8. Repeat steps 1-7 until the shortcuts work again if steps 1-7 don’t work the first time.

Note: It appears to be somewhat random (at least to me currently) when this 3rd method/troubleshooting path kicks in and works, so you may have to skip around and do any number of these combinations to get the shortcut to work—in the case I have detailed below. This is just what seems to be working for me. @roosterburton may come up with a fix/LingQ may figure their shortcuts out, but I just wanted to include this in case it helped anyone else! :smiley:

P.S. Trying a different key combination for shortcuts that are finicky might help, too.

Part of Original Post (not troubleshooting guide):


Edit 5: See this reply for the next update.


Edit 4: See this reply for an update.


Edit 2: Note: I noticed the next page shortcut default for LingQ: [hold down] Shift + right arrow worked once I uninstalled the Rooster HotKeys extension, but when I reinstalled it, and tried to do the same default shortcut it stopped working.


Edit: Yeah, seems like the LingQ Keyboard shortcuts are flaky in general, so there’s not much to be done until LingQ figures this out, so I’ll uninstall for now and try to mess around with LingQ’s shortcuts and report them to their support team, and revisit this extension. (Looks great overall! Once it can work for me, I would love to reset a few—handful—bindings I would use. Note: If you don’t struggle with LingQ’s shortcut keys issues, this won’t apply to you.)


I’m not sure why it’s not working for me, but not even the original shortcut from the LingQs side works for me when it comes to moving to the next page. Are LingQs bindings (and maybe even these bindings) more friendly to non-mac users?

I tried setting the next page hotkey to the command (a.k.a. “meta” ?) + arrow right (:arrow_forward: ), but it’s just doing the move to the next LingQ thing for me.

Additionally, in this case, the arrow right (by itself) also moves me to the next LingQ (which is what I want it to do anyway, but not on the command/“meta” + arrow right shortcut).

So it’s like it doesn’t even register that I’m pressing command/“meta” at all.

Edit: I can right/ left (:arrow_forward: /:arrow_backward: ) arrow in either direction until it moves onto the next page—not very practical—though.

Anyone with a MacOS experience this? (either on LingQ—without the Rooster Extension—or with the Rooster extension)?

Also, the default keybinding for Translating (Shift + T) triggers my Firefox browser to open up a new tab, so it’s extra weird.

Any thoughts @roosterburton? (I understand this may be out of your scope here, just wondering.)

1 Like

Not sure about this @jpp025. I just rebound that key to Ctrl+v and it worked well.

Try press Reset binds before making any changes.

Not sure about this either. I obviously haven’t tested the Meta key but the code looks right.

Shift+T is just the translate sentence toggle, you need to be in sentence view for it to work. There is a different bind to trigger the lesson translation.

Not sure why it triggers new tab either. I would need a MAC to properly investigate.

Do any of the keys work? Is it just these keys that are broken for MAC?

2 Likes

Updated to 1.26 and everything is working great over here, using these custom binds every day and it’s making such a difference. Thanks again for all the work on this @roosterburton!

1 Like

Great idea.
Please consider
-a key to show showing statistics
-always showing wordsread today
-a macro to go to the next sentence, show the translation and play the audio. Possibly mulipleorders. Possibly with a delay.

1 Like

Great idea, I’ll add this in the next patch.

I’ll have a look at how the data is created for this and get back to you

I’ll allow easy custom setup of automated keybinds in the premium version

2 Likes

Additional Edit:

Re-binded to “Shift + >” and seems to work more reliably than " Shift + :arrow_forward: " I’ll try it out for a bit and see. (I did a re-bind on the audio shortcuts that had that code for now 5 for 5 sec backward and 6 for 5 seconds forward and that worked. I tried the Shift + :arrow_forward: combo first and that didn’t work, so I went for the numbers instead.)


I’m still re-testing everything, but the short of it seems like just the " b " for “Next Blue LingQ” isn’t working, once I manually click on the next blue lingq the other LingQ actions appear to work.

Resetting the binds and uninstalling and reinstalling seemed to work(?) When I reinstalled Rooster Hotkeys to start testing all the shortcuts, the Shift + [arrow right/left] are working for me!!! :smiley:

1 Like

On my mac I often have to refresh the page because the shortcuts will stop working after extended use of lingq in one tab, regardless of roosters extension – the shortcuts always have been a bit flaky for me, no idea why. I’ve read that other users reported memory leaks on lingqs side, but I’m not sure if that could have to do anything with it. Can’t remember if I have the same issue on my linux.

2 Likes

I get serious memory leaks on Chrome if I leave LingQ open a while. That’s why I use Firefox.

@bbbblinq

ROOSTER HOTKEYS PATCH 1.27
→ Basic Tab system added


→ New bind (Toggle Stats Menu)
→ New bind (Show Words Read Today)* This auto updates every 30 seconds
image

Great to hear! It would be cool to know what keybinding configurations people came up with. Its a complicated problem now with duplicates and lots of unbound keys

2 Likes

Not sure why, but after changing the hotkeys once, whenever I revisit LingQ, the keys are reset and the tab dissappears.
Nothing seems to work except uninstalling and reinstalling the extension, resetting keys and changing them again, each time this happens.

Edit: Actually the extension just isn’t appearing at all now, I enabled permissions but still nothing. Not sure what’s interfering in this case.
Edit2: Seems some other web extensions like ‘leechblocker’ and adblocker aren’t compatible.

1 Like

@Vardan_Yervadian

The problem might be related to LingQs page navigation. They use a special navigation which doesn’t properly detect URL changes. You can try refresh the page when you are on the reader page it should show up

How could I use this fantastic ability on android phone?

1 Like

I’m not sure, does an android phone have a keyboard? Or do you mean for other extensions?

Some of these extensions are coming to Firefox for Android later this year

1 Like

Update 2: Legit resetting the binds, toggling the extension off and on again, and refreshing the page* often makes the shortcuts work again, this more likely a LingQ website/coding issue in my mind—not the Rooster Hotkeys extension.

P.S. I did the above again today and the go-to-next blue LingQ shortcut randomly worked again.

*I do this when the LingQ tab may have been open on a tab/idle too long.

P.P.S. Thanks for taking the time to reply @sarjag! It helped!! :smiley:

1 Like

The questions that keep me up at night. Why does this work on Chrome but die on Firefox and vice versa…?

hopefully we can find a solution where you don’t need to do that everytime!

1 Like

This page gives lifetime total words read. If you can pick up the first number, round it and show it, it would be useful.
https://www.lingq.com/api/languages/fr/stats/
{“Words of Reading”:81313.5551332149,“Hours of Listening”:1.10860720867366,“Known Words”:4979.0,“Hours of Speaking”:0,“Words of Writing”:0,“LingQs”:1802.0}

I’m trying " Rooster Reader for LINGQ" and I can’t see how to make it work - it does not appear.

image

2 quick ideas to add to the pile:

  1. Setting spacebar to a keyboard shortcut in the rebind menu displays a blank space, it could maybe be labelled with the word “spacebar” so you know the entry went in correctly and isn’t just an unset key. I started using spacebar for play sentence audio while in sentence view and noticed that it entered a blank space when I was binding it. The key works perfectly fine though so there’s no issue with the binding itself, just the way it’s represented in the gui overlay could maybe be made more clear.

  2. An assignable shortcut to toggle between sentence view and page view - the button in the bottom middle of the web reader.

The new toggle stats menu shortcut is surprisingly useful too, I didn’t know I wanted that until you put it in!

1 Like

ROOSTER HOTKEYS PATCH 1.28

→ Fixed!

→ Added!

You can thank @bbbblinq for that one

1 Like