Editing lessons

When I share a lesson with the public, and other people use that text, can I go back and edit the text at a later date if I find an error?

I have not shared lessons, but since paying members can edit any lesson they want, I would have to think you can also.

Yes, you can.
Moreover, you should do it.

I actually don’t have the option to edit lessons any more. It disappeared some time ago. Is that normal?

I was able to do it just now… Going into someone else’s lesson, Menu, Edit. Saved it also.

1 Like

!! I didn’t know other people’s lessons could be edited. Good to know.

I am not quite sure exactly how this has worked before and so on but I did remember that some time ago (might be already a year, time flights by so quickly), I noticed some glaring errors in some of the Swedish and a few in the Finnish ones. I reported these errors to lingq and Steve said, that he would give me a “editors pen” since I am fluent in Finnish and Swedish.

So in my experience you are able to edit lessons from the library, you just have to ask for permission. There is of course one problem with this “editors pen” thing and that to who should you give it to, how do you make sure that the person to whom this responsibility is actually qualified for the task.

Maybe they removed the functionality, the idea seemed to get mixed reviews. Have to dig up an old Mark thread to find the announcement.

@Estela - Yes, you can always edit any of your lessons.

Otherwise, Miznia is correct, all Premium members can edit any lessons they use. We are no longer giving out editors access. We opened this up to all Premium members assuming that the masses will do a better job of ensuring our lessons are as good as possible.

1 Like

I definitely do not have that option any more. I used to have it, but then it disappeared again.

It should be there if you click the Menu icon in a lesson. You should see the Edit button in the menu that appears.

Except it isn’t. I’ve checked several times and I’ve had it in the past, so I know where it should be.

Looks like you’re right. You had purchased a group buy offer after previously being upgraded normally. Technically those offers are for new members only but it looks like you were able to take advantage. Anyway, those group buy tiers didn’t have editing access. We are fixing this so it should be there in our next update.

1 Like

I figured it might have something to do with that. Well, there was no mention of those offers being for new members only and I had to contact you because I had activation problems, so I wouldn’t call that “taking advantage”. I was just surprised to see the feature gone all of a sudden.

1 Like

I have tried to make a few edits to lessons where the written text is clearly not what is spoken in the recording.
However, after I make the edits and hit save, I just get an error message “An error has occurred while processing your request. Depending on the type of error, it may be automatically logged and reviewed by our team so please retry your request in a few minutes. If you are still getting this error message after a few minutes, please email us at support@lingq.com.” and the changes do not go through.
Please advise. Thanks.

Sorry to hear that Darkslide820. Does this happen for your own imported lessons also? Or, just when editing lessons that have been shared by others? Which browser are you using? Does it make a difference if you try this in a different browser? We aren’t hearing this from others so there must some quirk related to your account that is causing this. Any more information you can provide will help us track down the issue. Thanks!

I was trying to fix a lesson awhile ago and still can’t fix it, receiving the same error message as Darkslide820:

(The issue needing to be fixed is from this thread:
Hi, Good Morning... In The Audio Of The Text I Hear Deal,... )

So possibly it is something about the lesson?

It happens in the lesson titled “HSK中级口试 第三部分 回答问题” in the course “My Writings.” It is not my content. The error comes up whether I hit “Save” or “Save + Open.”
Funny thing is I actually just today edited the French ministory #1 and it processed without a hitch.
I went back to the Chinese one above and still no luck. Didn’t matter if I typed in the correction with my Chinese (Traditional) keyboard or if I copy&pasted Chinese (Simplified) from Google Translate.
I’m using Google Chrome. I used to use LingQ in Internet Explorer but use it exclusively in Chrome since it works much better here.

I was able to fix that lesson. Must be some strange issue. Thanks, we will keep investigating.

Thanks, we will keep investigating this.