Deleted lessons still show in continue studying

I deleted a couple of imports in Portuguese, but they still show in my list. If I open them it shows not found.
That’s a little confusing as I try to keep my study corner neat, I’m also worried that if I need to downgrade they will count towards my imported lessons. How can I remove them for good?

1 Like

I had this problem too, and I reported it. I ended up deleting the courses with the imported lessons, and starting again. The problem seems to be fixed today. Deleted lessons seem to be deleted, and the lesson count for the given course is adjusted down accordingly.

This should be fixed now. Let me know if you notice the same problem again.

Unfortunately, the lessons still show in my list. I tried to delete the course, same outcome. I can’t get rid of them

I managed to delete some lessons, but as I thought the import counter doesn’t budge.

Also: the deleted courses don’t show, the deleted lessons are still there.

It’s a mess this thing. I’d like to keep my Continue Studying neat as well but it’s becoming more and more frustrating.

I have ghost courses and lessons. Now most of my courses have a white (+) and I can’t delete them as they reappear. :S

No, this isn’t fixed. I have sevaral lessons which I can neither open nor delete.

1 Like

I also cannot make a course I wish to delete disappear. I imported an e-book that did not format correctly and wished to delete the course and all of its lessons. I managed to delete al but the first lesson, but no matter what I do, the course remains in my Currently Studying list. I also want my list to be clean.

Actually now it’s worse. I have many lessons that can’t be deleted and are ghosts. In more languages. It’s becoming a nightmare. And I still have those ghost courses on my library as well.

1 Like

This problem has returned for me as well. I’m trying to delete an imported lesson in a private course, and I get the error message “lesson: Invalid pk “11453898” - object does not exist.” I think that the lesson is actually deleted in their database since the lesson count for the course is accurate, but the system is having trouble stopping it from being displayed.

1 Like

I also have the same problem with some deleted lessons in Chinese.

Yeah, I have 20 of those unfortunately, they are multiplying like rabbits. :open_mouth:

Sorry everyone! We will have it fixed asap.

has been issue since beta

1 Like

I have also just created a “ghost lesson” that can neither be deleted nor openend. If I try to delete it, the following message appears: “Invalid pk “11622074” - object does not exist.” I hope that this problem can be solved because deleting the whole course is not an option for me (since I want to keep the other lessons).

The issue doesn’t seem to have been fixed. I still hsve ghosts in my queue, that can’t be deleted properly.

I was thinking of coming back to premium, but if this issue remains I would not be able to downgrade anymore, if I import lessons, as they cant be deleted. I’m adamant about this, as money is tight and I dont want to delete the language in the end.

But especially the new lingq does work best with the imports

1 Like

when I regenerate the lesson/sentence it looks the same as before in the courses. My courses have 78 lessons and when I click on the courses I only see 1/3 of the lessons when scrolling down. a month ago everything worked. I noticed that lingq takes 4giga ram and starts slowing down the computer. I use safari and chrome. my computer MacBook Air (Apple silicon) - Wikipedia

Ditto on this.

Thank you, It’s look like everything now working

1 Like

We will look into it, thanks for your patience @Safran.


The problem is occurring again.

I tried to delete a course and saw a popup saying it had been removed from CS, but this is not the case.

I can no longer open/edit the course, but it still appears when it should have been deleted for good.

1 Like