Chrome Extension: LingQ Here problems

Wow–LingQ Here made the words blue and lets me make LingQs. But when I click a word, it opens a box with the possible definitions which can’t be closed or moved. And it covers the next part of the text I need to read… (same website as previous post).

Later: discovered that to close the definition box I need to click in the blue text again, not the prominent red X that seems to say “click me to close.”

Also, can’t select phrases (I realize this may be asking a lot)…

The extension only blues the words in one portion of the page. Other portions are immune… Or is there a way to move LingQ to a different part of the page?

@stanh - Honestly, the on page function of the extension is very finicky and changes depending on how the page has been set up by that site developer. I would recommend the learn on LingQ option over the on page option every time. It opens quickly, is less glitchy and lets you create phrases.

I would love to. However, as I mention in another post, attempting to “Open on LingQ” results in a message that the page is importing which soon goes away. But when I go to “My Imports” on LingQ, there is nothing there…

Have you tried this on multiple sites or does this just happen on one? Can you send a url for a page that isn’t working?

I have just tried the following URLs, all with the same result (it says it is importing, but there is nothing in My Imports). I disabled Privacy Badger and AdBlock before testing these sites.

The first site doesn’t load for me so I couldn’t try the extension there but the other sites all work fine. But, most of those pages are index pages. So, you first have to open an article page to import it. The importer doesn’t scrape the site. It just imports the title, text, and image from whatever article page you are on.

Okay, I tried a non-index page (after disabling all extensions except LingQ):

Same thing–it says it is importing but nothing shows up in “My Imports.” There must be something about my system and setup that is causing the problem. But I have no idea how to troubleshoot it. I am running OSX 10.11.6 and the latest version of Chrome. Any ideas?

It should say importing to LingQ, and then “successfully imported”. Then, I click the Open on LingQ button to actually import it. Is that what you are doing? You need to click the button to actually import it and then wait for it to open in a new tab.

1 Like

Okay–here’s exactly what happens:

  • navigate to page
  • click LingQ extension icon
  • it says “importing to LingQ”
  • when that stops, the LingQ bar disappears
  • click LingQ extension icon again
  • click Open in LingQ button
  • nothing happens

Never does it say “successfully imported.”

That’s very strange. That’s what I’m doing and it works perfectly for me. Here is that article - Login - LingQ.

i’m not sure what to suggest. Can you open your javascript console under Developer tools and see if you see any errors there?

(Weird–there is no longer any way to reply directly to your messages–I have to scroll up to a previous message and reply to it. This is a very strange way for a forum to work.)

I followed the link you provided. It seemed to be doing something, then said there was a problem loading the lesson, then went to my lessons page.

You’ll have to give me very precise instructions to do what you suggest–I have no idea where to find developer tools or javascript anything. Thanks.

"- navigate to page

  • click LingQ extension icon
  • it says “importing to LingQ”
  • when that stops, the LingQ bar disappears
  • click LingQ extension icon again
  • click Open in LingQ button
  • nothing happens"

I have exactly the same problem. Is there any limit to the number of quick imports or just imported lessons?

@stanh - Forum replies only go to a certain depth otherwise, they get too narrow to display properly. Replying above is fine.

To see Developer tools, click View > Developer > Javascript Console. This will open the console in a different window. Then, after you try to use the Extension send us a screenshot of any errors you see there.

@Nexus-6 - There is no limit to the number of imports you can have as a Premium member. Quick imports are the same as imports.

Thanks for the info. I’d thought there was something wrong with the Chrome browser on my desktop computer (maybe because of some other extensions or plugins) but I’ve just found out the extension is not working on my laptop either.

@Nexus-6, Stanh - Can you try enabling “Allow in incognito” in your Chrome Extension settings and then trying to use the extension in Incognito mode? Just to see if it is another extension causing the problems.

I enabled “Allow in Incognito” and used the extension in Incognito mode. Still the same result. :frowning:

@Nexus-6 - Please send the page you are trying to import. Also, what operating system are you on? And what version of Chrome?

OK, I’ve tried to import a lot of pages already. For example I tried to import any articles from this website:


My OS is Windows 10 Home.
Chrome version is: 52.0.2743.116 m

The notice in green about the text being successfully imported to LINGQ never appears and it never takes me to LINGQ. Sometimes the second option does work - lingqs appear on the page but I can never find it in my imports anyway and it usually crashes after a few minutes.

@Nexus-6 - You’re right. The extension doesn’t seem to be working in Windows Chrome. It is working on my Mac. We will see what is going on there. Sorry about that.

1 Like