[BUG]



Thanks. We are familiar with the problem and our developers are looking into it.

1 Like

hello I’ve got bug when I try regenerate lessons ( Failed to regenerate lesson)

1 Like

Hi! Could you share some more details about what happened?

Same for me, I didn’t do anything special but to click the regenerate button (tried 3 different lessons in the same course, it takes 1 min then I get the ‘Failed to regenerate lesson’ bug message).

edit (correction):
→ click the regenerate button
→ change something
→ click somewhere in your screen to save / save it manually
result:
→ loads during 30 secs
→ ‘Failed to regenerate lesson’

1 Like

Hello, I am trying to import lessions in Italian. They are based on YouTube videos. All of them are about 20 minutes long. Whenever I create a lession, the transcript is being truncated after about half of the text. The transcript is pure text and does not contain any punctation characters. The size of the text per lession is about 25kB and contains ca. 630 lines, seperated by CR. After the import, LingQ appears to have automatically created one paragraph per line of text. Because only the first half of the text is imported, I always get about 320 of these paragrafs. Though, the number of paragrafs, after which the text is truncated, varies from lession to lession.

When text you are importing is longer than 2000 words, it will be split in parts. Are you sure that additional parts weren’t imported? Can you check the same course again and confirm?
Regarding the punctuation and other formatting issue, unfortunately that’s related to SRT (subtitles) file imported for that video and there’s no much we can do. Our importer just grabs existing subtitles and make a lesson of them, but it can’t change formatting or add punctuations.

Well, when I imported the text there was only one text box where I could put my text. The text is definitely longer than 2000 words. It seems, you’re right. A second lessont had been generated by the system.
This has worked for only one of my lessions. Only the lession for which I had edited the transcript, adding punctaion and correcting errors, the system created a second part. All other lessions have only one part with only the first half of the transcript included.
Even if this mechanism worked correctly, from a usability standpoint, I’d like to have one lession. This way, I have to search for the second lesson when the first runs out of text.
Is there a plan to remove the 2000 words limitation?

1 Like

Here is a link to the lession which was split successfully by the system:

And here’s the link to one of the lesseions which the system didn’t split correctly:

I’m having similar problems. The generate timestamps button is returning “Failed to generate timestamps” and I usually don’t have problems getting it to work. My operating system is Linux Mint, in case that’s relevant.

The lesson which was split successfully works well, though. The audio was split as well, as it seems.

@alexanderburkhardt At the moment, we don’t have in plans to remove this limitation. Lesson and site performance are significantly improved by avoiding to have too long lessons. That is the reason we added this limitation.

When did you import that lesson that wasn’t split properly? Everything appear to be working properly now, so you should no longer have this same problem.

We are looking into the issue and we will have it fixed asap. Thanks for your patience.

1 Like

Ok. I’ll try to repeat the import for the 6 lessions which weren’t split.

Ok, I see. I completely agree with this idea in principal. Though, as my level in Italian increased, I started to like longer videos. For me the optimum is now around half an hour. However, as long as the splitting works fine, it works fine for me. Thank you for the explanation.

Thanks zoran, appreciate it :slight_smile:

The problem, that a lession longer than 2000 words wasn’t imported correctly, happened again, yesterday. This time I used the LingqImporter extension in Chrome to import this YouTube Video: Secretos del Universo. Sumérjase en el espacio profundo. - YouTube.

I only got the first lession: Anmelden - LingQ

The rest of the video was not converted to lingq lessions. At least I cannot find any.

The same happened also with this video: Perché ci si ammala sempre più di Cancro? - YouTube
Only the first part was imported:
Entra - LingQ

Sorry about that. Please give it another try now.

It seems that when I import the lession again, lingq finds the previosly imported lession and doesn’t change it. I tried this one, as it’s longer and more important to me: Secretos del Universo. Sumérjase en el espacio profundo. - YouTube.
I couldn’t delete the lession to completely regenerate it either. The lession seems to be in use. Then I tried the function “Regenerate”. But nothing changed. Only a single video exists.