App troubles? Not anymore :)

If you’ve had issues with the LingQ IOS app lately, we have some great news and are happy to tell you that we have fixed it and cleared out the bugs - so give it another chance.

If anything weird occurs let us know.

Good luck and good language learning :slight_smile:

1 Like

Hi guys
I just installed an app again but a problem that i have this time is when i click on blue words i have 2 option copy or add to lingq so far is ok but when i chose add to lingq it jumped out off the app :pensive::pensive::pensive::pensive: i am using iOS if it helps.
Please solve it it is about 1 month that i could not use app which is really bad​:pensive::pensive::pensive:

That sounds really annoying. I am trying to do it on my iphone right now and I am not experiencing the issue you describe.
This isn’t great advice, but maybe you can uninstall the app and reinstall it AGAIN. Other people are experiencing the same issues. Check out this threat

We are working on getting it fixed ASAP. I apologize.

Hi lyx. Thanks for the effort in fixing the app. I assume you are refering to the iOS app here. Unfortunately, the latest update seems to have caused more problems that it has solved. I find the app is now very unstable and there are problems when making LingQs. I will describe the main problem that I have been experiencing since updating the app.

This is the typical chain of events

  • I am reading a text and saving blue words. At some point, seemingly at random, a problem appears. Everytime I save blue word, it initially becomes yellow, but then quickly turns blue again. When I press on the word to see it, it is clearly a LingQ and not a new word (so it has in fact been saved), but it is displayed in the text as a blue word.

  • I reload the lesson and the word I just attempted to save is marked yellow in the text, so as before, it has indeed been saved as a LingQ. Then, I try to save the next blue word and the app crashes. This crashing happens 100% of the time after the problem described in the last point.

  • I then reload the app and lesson and continue reading and saving words. At some point, randomly, the problem described in the first point appears again.

This is very annoying. If it can be fixed, I would very much appreciate it. If that will take time, maybe it would be possible to replace the current version with the previous one, since it worked better.

There are in fact other problems with the app that I have noticed but not reported yet. Here are two of them.

  • Open a lesson on the app and start to play the audio. Next, while audio is still playing, open a different lesson. Notice that the audio continues to play, and when you start playing the audio of the next lesson, the two just play ontop of each other. Even when you go back to the original lesson, you are no longer able to stop it. The only way that I know to then stop the audio is to shut down the app.

  • Go to a lesson which has some new words in it. Select one of the new (i.e. blue) words and have a look at the list of previously saved user hints. Then save the word as a LingQ. Now select the word again and press the little + sign next to the hint that you saved. What you should get is the list of hints again, and indeed this is sometimes what comes up. However, more often than not, the list of user hints is now displayed as empty and you only get the Google Translate version.

I know, I know. I apologize… It seems it has gotten even worse for some people. I do mean the iOS app, yes. I have it on my iphone 5 (that’s falling apart) and have un- and reinstalled it and everything works dandy - but that’s obviously of no help to you. We are working to fix it and hopefully it won’t take very long. Again, I apologize. I will let you know as soon as improvements have been made. :cry: I’ll try and find out if we can revert to the previous version.

I also can’t make these happen but will report this. For the audio issue, are you doing this on an iPad? I can’t go to another lesson on my iPhone without the audio stopping.

@soolii When you tap on blue words you should see the blue popup which slides out of the side of the page. Do you not see this? It shows previous user hints which you can tap on to create the LingQ and turn the word yellow. The options you talk about are when you select a word in the text and then try to create a LingQ for it. This also works fine for me when I tap Add to LingQ, the same blue popup slides out from the right side of the page.

Which device are you using? Is it an iPad or iPhone? What version of the app? Check the info page by clicking the Info link on the main course list page.

Yes, I am using the iPad. I just reinstalled the app.

The audio issue is not present on the iPhone but still present on the iPad after reinstall. I don’t know if the crahing issue I described in my first post is still happening. I read a short text and it didn’t happen, but likely that was just because it only happens randomly anyway.

Ok, I have reported the audio issue. Please let us know if the crashing issue still happens now.

Ok, I’ll know soon. By the way, I really like how this (relatively) new notification feature works, but why do I get a notification every time I post on the forum? Is this intentional?

Good catch! You should not be notified about your own posts. We will get that fixed.

1 Like

Ooooook, so the problem still happens, but I have a little more information. The crashing of the app and the fact that newly LingQed words turn blue again are unrelated. The app crashes on my first attempt to create a LingQ after I have opened the second lesson, i.e. after loading up the app, I open one lesson and everything is fine, but then I open a second lesson (which could just mean reloading the original lesson) and the app crashed when I try to make a new LingQ. This happens every time, without exception.

…and if it helps, the LingQ that causes the crash to happen is made nevertheless.

Can you reproduce this on your iPhone or does it only happen on the iPad? I assume you are doing all of this in Landscape mode on the iPad?

It only happens on the iPad. On the iPhone, it is fine.

The problem is present for both portrait and landscape modes. However, it doesn’t arise if I change lessons using the Previous Lesson and Next Lesson buttons.

You’re right:. Thanks for tracking this down! I can re-create both of those issues on my iPad as well. We will get those issues resolved.

Ok, glad I am not just going crazy. Could you also reproduce the issue with the list of user hints not appearing when trying to add an additional hint to an already created LingQ?

No, I’m not able to reproduce the issue with the blue hint pop up. If I add a hint and then reopen the yellow pop-up and tap the plus sign I get the list of all available hints every time. I’m not sure why that happens to you. Sometimes there can be a bit of a delay before the hints show up but that usually only takes a short time.

What language have you tried it for? I just opened a French text and this problem appears not to be present. However, in German and Russian texts, the problem is present.


“What language have you tried it for? I just opened a French text and this problem appears not to be present. However, in German and Russian texts, the problem is present.”

I can’t recreate the problem in any languages that I’ve tried including German. If you can keep trying to find a pattern for this one, that would be great. We need to be able to recreate it somehow. Any more help would be great.