Android App Update

We have just uploaded a new version of the Android app which should be more stable and which allows you to install the app on the SD card. We continue to work on improving stability so bear with us. Thanks to spacejumper Login - LingQ for all his hard work!

Well… the post-offline synchronization just doesn’t work as it has never done.
How can one single bug go through so many releases?

We haven’t forgotten about you, eugrus! I know it’s been a problem for a long time, but we should be releasing more frequent updates now that spacejumper is helping with the development. One step at a time – we’ll get there!

Well, even after a complete reinstall I’m getting “Error Network connection lost!” with an option to either retry or work offline. Retry gives me the error again and work offline isn’t very useful since none of my data has synced. Android 2.3.4 if it matters. And before you ask, yes I was connected via WiFi when I tried the app out.

I have to say that I share eugrus’s frustration. This version is unusable for me. The last version I could open lessons but couldn’t view any lingqs and I could review flashcards but the sync problem makes that kind of pointless. Then the version before that I couldn’t even open lessons. I’m glad you brought on another developer for this app, clearly its needed.

Thanks for reporting this. I have noticed that the app is a bit sensitive, so if you get this error and know you’re connected to wifi, try closing it and reopening it to see if that helps.
As Mark mentioned, we’re working hard on improving the stability of the app. We will get there, but we ask for your patience as we sort out the deficiencies in the app

Unfortunately, I can also not use this version of the app due to the “Error Network connection lost” issue. I will continue to use LingQ through the mobile browser for the time being.

Same problem here. Glad to know it’s not just me…

Alex, I did log out and in again, but it didn’t help. :frowning:

I’m new to LingQ, but I’ve tried the android app of iLingQ. I’ve gotta say, this is the only app which absolutely 100% of the time crashes my phone…and I’ve got a pretty reliable phone with quite a few apps on it. A bit disappointing. I had to uninstall the thing. Waiting for bug fixes before I try to re-install.

@RickyRuffcutt - Is this on the most recent version, 2.2.1? Any additional information about what you’re doing when it crashes will be helpful!

@Alex - not much to explain about it. When I first downloaded the app, it seemed to work ok. The only thing at the time that I noticed was it’s inability to handle the playlist feature well. As I began adding more lessons to my lingq account and using the site much more often, I noticed the app on the phone slowed, and slowed and now it won’t even load up without crashing. Without fail… as soon as I start it, it slowly tries to boot then it crashes. And this is whether I’m using wireless or 3G connections. I have to restart every time. So yesterday before writing the post here I uninstalled it.

And yes it was the latest version. You pushed that version before I became a member.

Alex, I have almost always had the same problem, both with wifi or 3G connections. That’s why I repeatedly installed and uninstalled the app. After you pushed the latest update, I’ve NEVER been able to open any lesson or even view the lesson list, because I would immediately get the error message “No network connection” (or something similar).

@RickyRuffcutt - OK, thanks for the details. Sometimes reinstalling, even with the same version, does help. I encourage you to try this and let us know if it helps at all!

@mikebond - We haven’t forgotten about this one, but it’s proved a bit trickier to fix as it seems to only be affecting certain users. In the meantime, please check your email.

Thanks, Alex. I will try it this week-end. But can this version be installed on the SD card? I don’t have enough free space on my phone internal memory…

The ability to move the app to the SD card was added in version 2.2, which was announced in this thread.

Oh… then I will probably wait for the next version. :frowning:
Anyway, my smartphone is not my main device to study languages…

I’ve taken your advice and re-installed it just this minute. This time what happened was, the app seemed to work smoothly at first, and the instant I added something to my playlist it slowed and froze the entire phone.
I’m about to re-install and see if any other functions will produce similar effects. All done using wi-fi by the way.

Update: @Alex, re-installed again. So far so good. I haven’t touched the play-lists however, so I’ll keep it that way and report back if something other than play-lists causes a freeze or unbearable slow down.

Have just installed this for the first time, it has let me log in and select language Russian, but every time I try to do anything else it says connection lost. I’m on my home wi-fi.

Having just read the whole thread I see this is a common problem. Especially as I’m on an old version of Android, with the apps stored on the SD card, I guess I may not get the iLingQ app to work on my phone.

@RickyRuffcutt - OK, great. We’ll look into the Playlist issue and see what we can find out.

@skyblueteapot - Yes, this seems to be the same issue that mikebond and odiernod have reported. The newest version of the app can be moved to the SD card, so depending on your version of Android you should still be able to run it. The specifications for the app are version 1.6 and up.

Ah, I think I have Android 1.5. Practically Stone Age :wink:

the android version cannot play and progressively download the mp3, unlike iphone. supposed to be like that?