About the new LingQ Android App

Hi, LingQ staff

First of all, thank you very much for creating a LingQ Android App.

I have been waiting for the time when I can use it for a long time. I have used LingQ site itself on my Android cell phone and been doing vocabulary reviewing in commuting on the crowded train (which is notorious in Japan) so far, though the letter size is very small and it is inconvenient to use.

I immediately started to use the LingQ Android App on my cell phone, though I noticed some problems. I don’t know whether these problems are applicable to only mine, though I hope you would check them out.

#1 Every time I open the LingQ app, the sign “Error! Retry or Work Offline” appears. When I choose “Retry”, the same message “Error! Retry or Work Offline” keeps appearing. When I choose “Work Offline”, I can use Daily LingQs.

#2 When I use Daily LingQs, the Hint does not appear on both front and back of the flashcard, even though I put the checks on them on the setting page.

#3 Not all of the phrases can be seen on the back of the flashcard because of the “Oops!” and “Got it!” buttons when the phrase is a long sentence.

My cell phone is Galaxy S from Samsung. Thank you very much in advance.

I’ve reported #1 and #2 via email to the Support too.

I am experiencing issues #1 and #2 listed above as well. I haven’t seen #3 but I didn’t try that many cards. Issues #1 and #2 seem to consistantly happen every time I try to view my lessons (#1) or flashcards (#2) respectively. Also, none of the lessons show up. I am using an HTC MyTouch 4G Slide from T-Mobile. It is running Android 2.3.4.

I am experiencing issues #1 and #2 listed above as well.
#1 randomly though.
Samsung Galaxy Tab 7".

Thank you all for reporting these issues. We have now taken note of them. If anyone is having any additional unmentioned issues as well, please let us know.

No problems to report, as I don’t have an Android phone. And this is sort of off topic, but . . . very nice to see a Jules Verne quotation was chosen for the announcement! Well done! :slight_smile:

I’ve noticed several things.

  1. the contents miss some words.

For example, it drops “toi” when there should be “Détends-toi”.

  1. the audio keep playing even when I logged off. This happened from a moment when I clicked “back” button, when it showed me “fetching text”.

Thanks for the app for android! :slight_smile:

Those of you experiencing issue #1, the “Error! Retry or Work Offline” message, this message appears when you don’t have a proper internet connection. The app checks to see if you have internet because some functions require internet. If you don’t have internet, you are switched to offline mode. Are you getting this message even when you are online? This is not happening to me.

Those of you with issue #2, no hints on the flashcards, what version of Android and which device are you using? Also, what do you have selected for display on the front and back of your flashcards on the Settings screen?

Issue #2 appears all the time. On Samsung Galaxy Tab 7, Android 2.2.
Hint never appears, whatever item is selected.

Mark, I tried using the Android app with a 3G connection and I did experience issue #1, especially with the English library (too many active lessons?). I have a Samsung Galaxy Ace with Android 2.2, I think.

It seems issue #1 only occurs the 1st time (sometimes the 2d time too) you launch the application, also when internet connection is good. Perhaps not enough time to load all the lessons the first time?

Issue #2 only occurs if you choose “Daily lingQs” (bottom right) immediately from the beginning, without opening a lesson. If you open a lesson and then tap “Cards” (top right), it works fine!

Tried on htc hero Android 2.1 and Samsung Galaxy Tab Android 2.2.

I am on the internet when I receive the “Error!” with the “Retry” or “Work Offline” options. This happens every time after the “Fetching lessons” message. I have tried this while connected to WiFi as well as a 4G connection. Once again, I am using a HTC MyTouch 4G Slide from T-Mobile running Android 2.3.4.

As for the flashcard issue, I only have term selected for the front and I have term, phrase and hint selected for the back. Not sure if this helps but I tried clicking the “Edit” button and then “Edit Hint” while viewing the flashcard and the text field showed up as blank. The same is not true for the phrase, it will show up if I click “Edit Phrase”. I’ve tried editing the hint both before and after flipping the card and had the same result. I’ve tried about a half dozen different cards.

After looking at the above posts, I wonder what Android device you are using Mark or anybody else that isn’t having issues. So far everyone that has posted claiming to have issue #1 or #2 is using a device from Samsung or HTC:

HTC MyTouch 4G Slide (mine)
HTC Hero (jpljpl)
Samsung Galaxy Tab (jpljpl)
Samsung Galaxy Ace (mikebond)
Samsung Galaxy S (hirohide)

I am on an HTC Hero and I have also just started experiencing some of these issues. I seem not to be able to see the Hint on the Daily LingQs flashcards only. In the lesson flashcards I see the Hints every time so far. I don’t have issue #1 which is the message about being offline. This could be because you have too long a list of active lessons to load on the app before it times out. Can some of you try archiving some of your lessons and then see if this causes the notification to stop.

By the way, on a related subject, we are not very satisfied with our current Android developer. We contracted out this project and it has taken much longer than anticipated, as any of you who have been waiting for this app to arrive will know! :stuck_out_tongue:

Currently, our ongoing iPhone app development is being done by one of our members, arsenius. This arrangement has worked very well and we have some great new improvements coming soon on that app. It is very helpful that arsenius knows our system, is a user and therefore wants the app to work well and has great suggestions to make it better.

Are there any of you out there who could help do the same thing for the Android app? Any Android developers who want to be involved in improving iLingQ for Android? Please let us know here or by emailing support.

Issue #1 also happens with LG-P930 (Android 2.3.5). Flash carding is smooth. Other than that, it is almost impossible to change languages - very sticky. Luckily, this high definition, super fast smartphone works very well with LingQ’s web pages (tiny letter size) and the app is not really needed. Still a pity though.

We’re working on an updated version of the Android app which will include improved functionality and improvements to the overall app as well. Give us some time to work out all the kinks!

I just bought a new Samsung 8.9 inch Galaxy tab ( essentially the same as the galaxy tab 10.1 just more compact…) it has android 3.2.

I’m experiencing some problems.

  1. The audio auto plays as the lesson text is still loading. Anyway to not make it autoplay . To allow the user to play when he wants… I would jsut pause it but the pause button hasnt shown up yet for some reason… Still would be easier to just not autoplay the lesson…
  2. My lesson lists dont refresh. There doesnt seem to be a refresh option. Even if i log out and log back in it doesnt refresh… Theres a few lessons I recently opened on Lingq That i wanted to study on the android App but they aren’t showing up in the lesson listing…
  3. The app is overall unresponsive and buggy compared to the iOS app on my iphone. It just freezes there in alot of situations…
  4. Audio keeps playing even though i logout or close the app all together ( NO the app isnt running in the background. I log out and and i close it completely in the task manager)… I have to open the app again and force close it in the task manager a second time to stop the sound.
  5. Sometimes theres 2 instances of the same or even different audio lesson that start playing at the same time…
  6. The text is kinda small… At least on my galaxy tab 8.9 . anyway to introduce a bigger text option or somekind of personal zoom option… I find it hard to click the proper word even with a tab pen.

I was excited to start using Lingq on a Tablet but at the moment it’s completely not possible for me to review lessons without running into issues. Its just not user friendly usable at the moment on my tablet.

Looking forward to a new update whenever that is… until then I wont be using the app.


  1. I’m also having the ERROR work offline after i login. Its not an internet connection problem… I’m at home using WIFI That works PERFECTLY FINE!
  2. I dont know how this app looks like on Android phones and how much screen space they have. BUT i was wondering after pressing a yellow ling if it would be possible to add the status numbers in the window much like how it works on the lingq computer version… Allowing the user to choose 1-4 from the lingq popup widget… Just saying … would be nice. I know you can do this in the flashcards but would just be more direct in from the lesson itself…
  3. the flashcards are slow to flip… I mean the animation itself. It should be alot more instant. Its not an issue of slow hardware. Its just really smooth slow flip over animation… I would speed it up by 100% …
  4. Flashcards. the Status 1-4 graphics are EXTREMELY squished at the bottom. BUt i suppose this might be an issue with Screen size on different devices… Theres no way you guys could have it work on everything.
  5. Flash card text is really small. Way too much white space on the card. Text should be doulbe or triple the size ( At least on this tablet)
  6. Changing the Status of the flashcard. When i click the number I want to change it too and other window pops up asking me wha tnumber i want to change the status to. ITs redundant. I already clikc the number at the bottom… Why ask again? Tooo many clicks … too inconvenient.

Thank you for the excellent feedback. We are actively working on several of the issues you raise and hope to have the updated version out soon.

big plus for having play list

After update it used to crash whatever I did (Major frustration here). After uninstall and reinstall it seems to work.