500 Server error

I get a 500 Server error if I try to delete any flashcard.

Can you give us a little more information? We are unable to reproduce this problem. What operating system and browser are you using? Does this happen for all words in your account?

Log in
Click on vocabulary tab
Tick one of your LingQed Terms
In ‘More options’ drop down list select delete
Are you sure box - click yes
500 - Server error

Firefox Windows XP Pro.

This is 100% reproducible & happens to all of my LinQed words but now I’ve checked seems to be specific to Firefox (or one of my addons). Doesn’t look like a problem in IE.

The URL that it actually tries to load is Login - LingQ


We have noted the problem you have. I just went in and followed your instructions and deleted some words in Russian. It took a little while, but it worked. Perhaps you have a slower connection than I do.

We have made some improvements and it is possible that this function will work faster in the next version that will be uploaded in a few days.

I will check in Portuguese and report back.

It worked fine for me in Portuguese and worked very quickly. Note that in Russian I have over 12,500 saved LingQs. I am in Firefox, but in Mac. Perhaps there are others that have experienced the problem.

Um… I wouldn’t have thought it’s a speed issue. After clicking yes to the delete confirmation it comes back almost instantaneously with the server error (we have 2Mb/s adsl).

Run out of time today but I’ll try it tomorrow with all the FF addons removed.

I found a PC and using Firefox was able to batch delete. Mystery. Anyway, let’s try again tomorrow.

I have tried both IE and Firefox. It works fine in English, Spanish and Russian. I have not a lot of words in the two last languages thouh, if this counts.
In English, I could deleted words of different status. At first in IE, after cliking Yes to deleting, it was written “page no found” in the LingQ widget. I tried again and it works.

There is the odd issue that crops up in the LingQ widget. We have been working on a completely new widget which we will launch tomorrow so hopefully all of these problems will be resolved at that time. Stay tuned…

It’s a mystery. I’ve another PC on the same network running the same OS & the same V of Firefox & that deletes fine. This PC, even if I disable all FF addons, always gives a 500 server error.
We’ll see what happens with the new widget…

New Lingq widget looks good although I haven’t tested it much. The 500 Server Error still exists though - on this PC anyway. I can delete a Lingq from the Workdesk ok (that’s always been ok) but still throws the error when deleting from the vocabulary.
Mark if you wanted to try & sort this off line I’ll help all I can.

I also liked the new widget - the previous one had annoy me with its sticky nature - but I also did not really work with the system after the changes. The 500 Server Error started to reproduce itself every time I was trying to switch from English to Russian language, from the Overview menu.

So yesterday I stuck with English and could not delete/archive unnecessary Russian content. Now I have checked it again - still the 500 Server Error.

I should add that if I try to switch languages from the very top from any menu tab, rather from the right panel available only at Overview tab, things are less reproducible. Sorry for being haste - have to leave now.

–continued from the previous post–

To specify, if I try to switch to Russian from the top of every page but the Overview page, I am allowed to see “Russian” without getting the error message. However, cicking then “WorkDesk”, with the intention to delete unnecessary Russian content , gives that 500 Server Error.

Windows XP, FireFox.

These language related issues should be fixed now. Thanks for your understanding.

It’s happening with me too, but only when I try to see the workdesk or to access the store… Is it because of changes in the system?

sacadura, what do you mean? You are getting an error when you try to access the workdesk? Or you are having problems with the language switches?

I take it that Mark is getting fully immersed in the culture of the language that he is studying and so has assumed the name Frencho. Very subtle.

You got me. Just trying to make it look like we hired a new employee!:slight_smile: