Youtube import- creating lesson takes forever

I tried to import a video of 8 minutes into LingQ. It’s been over an hour, and it’s still in pending lessons. When I click on the lesson, it keeps saying that it’s not yet available for reading, with a word count of 0.
I can’t delete the lesson either, to start over, because it is in create mode.

Am I doing something wrong, or is this a glitch? I have a video of one hour on youtube, and I am hesitant to import it, given the fact that this will probably take days or weeks to import?!

1 Like

I deleted the lesson in the mobile app. It was gone, now it’s there again. I still can’t open it. It’s been 8 hours (!)
I tried to import another lesson with the mobile app. Another short video. The first message read: success, do you want to open the lesson? When I said yes I got: error. Sth went wrong, please delete lesson and try again. The lesson is nowhere to be found.

In a nutshell: I can’t import anything anymore, which tbh makes the app useless! Please fix this ASAP

1 Like

I find good success either using the web plugin for Lingq on a “pc” or “sharing” a YouTube with the iPhone app. Rarely, but it happens, an import will hang. So, I try again.

On the iPhone, with the YT app either playing or ready to play the video, click share, find the Lingq app to share it with, get the parameters right when Lingq opens (Language, course, etc.), and start the process. Wait until Lingq tells you the lesson is ready to open. At that point you’ll either see that it has imported the transcript or is generating a transcript for you which takes a few minutes. At that point, you can either start reading in Lingq or dismiss the app and check in later.

1 Like

For me it is very common for lesson imports to never complete, the lesson gets stuck in the pending queue. I have one lesson that appears twice. One copy is good, but when I open the other, it says it does not exist. I cannot delete it. I always import from the YouTube app on an iPad. It is also common for the transcript to be corrupted. Thus one line repeats 50 times say in place of the correct lines. This is not reproduceable i.e. it is random. I have no idea if this is LingQ at fault, or the third party services they use.

With the youtube app on my phone, I managed to get the lesson working now. I had 2 copies pending but after reopening the lingq app it finally worked out.
I think it has to do with the new AI features, as I didn’t have problems before.


Yes, that worked out, after restarting the app. Otherwise I get the message that the import did not finish, but when I restart it can be accessed

1 Like