Won't allow me to add audio mp3 file

Hi I just imported a new lesson and tried to add an audio file but it won’t let me add it and won’t give me any explanation as to why it won’t add.

Sorry to hear that. Sounds like something is wrong with that specific file. Can you please reach me on support(at)lingq.com , send me that file and I’ll take a look. Thanks!

Hi Zoran. I have had this problem recently too but just assumed that the MP3 file I was attempting to add was too big. So sgjeffery’s question is a good opportunity to ask: are there limits and, if so, what are they? And is there any mechanism (e.g. third party software) that we can use to split an MP3 audio file in order to add it to a lesson?

Many thanks in advance.

I think it might be to do wtih size as the MP3 file was 63 mb. I didn’t know there was a size limit. It would be useful if there was a message that comes up to say something along the lines of ‘File too big to upload’ or something along those lines. Like Davidc411, I would be interested to know if there is any way around this?

1 Like

I have one as well at 54 mb that doesn’t upload either. And it’s less than 60 minutes. I don’t know if there is a size limit either I thought there wasn’t.

I’m pretty sure there is a file limit size, but no idea what that value is. It may also have more to do with “length of time” of the file. If it is a size issue, maybe you can compress the audio file further. I did a quick search and this site came up:

Caveat…I’ve not used the site at all. You might dig further regarding compressing audio files.


This is a good idea. Although we know there is a time limit but it would be nice to know or have displayed somewhere if there is a size limit as well. At least we know what’s wrong with those imports.

Thanks for the link. I’ve just used it, and it reduced the size of my file from 120mb to 48mb. However, when I then tried to add the 48mb MP3 to the lesson, I got this (strange) message: “The audio length must be between 10 seconds and 60 minutes. The audio you uploaded was 42 minutes and 46 seconds”. It won’t let me add that audio to the lesson. Not sure what to do now.

Zoran, please look into this for us.


Same thing happened to me with a similar message so I gave up to upload that file. I tried to check if there was something wrong with it but I don’t know what. It’s not protected or something.

me as well, it seems to be a problem with Lingq

1 Like

Hmmmm. I think this used to be an issue in 4.0 as well…is there an input field that allows you to enter the length of time of the audio. I remember there being one in 4.0. I don’t remember the circumstances, but I think there were cases when uploading audio where the input field might say 0 minutes (which is not between 10 seconds and 60 minutes =) ). HOwever, if you entered the length of time the audio is, it would allow you to upload.