Why is lingq not remembering my settings anymore?

For some reason Lingq does not remember my settings anymore. I keep getting the new members hints popup everytime I log in, and every time I change settings such as ‘paging moves to known’ , these are changed back the next time logging in. This is super frustrating.


These settings are kept in your browser with persistent cookies. If you browse in incognito mode, or have your browser configured to not retain cookies between sessions even if they’re persistent, or manually clear cookies, then those settings will be lost. It is a long-time minor peeve of mine with the site because it is my policy to not keep cookies when I close any browser.


I haven’t changed any settings, it just suddenly started doing this! Its mega frustrating. How do I configure the website to retain cookies?

Anybody? Please. This is bugging me so much I’m close to cancelling my membership here as it is too frustrating!

It is your browser that needs to be configured. Clear, allow & manage cookies in Chrome - Computer - Google Chrome Help

@davidrobinson Which browser are you using? Do you have any extension installed that automatically clears your browser’s cache and cookies when you close it?

I have my browser clear my cookies after every session too. The LingQ popups are still very very annoying, why can’t you guys just make it a user setting stored on the lingq server?

1 Like

Using safari, Not using any extension,. Any ideas how to fix it?

This has been a recurring problem. There are older forum discussions of this, too. The only solution I found was to start using Google Chrome for LingQ. I prefer Safari, but it is better to use Chrome than tolerate the settings being reset all the time.

By the way, it doesn’t have anything to do with cookies, though that is what most people will suggest, with good reason. But, it’s simply a problem with the way LingQ interacts with Safari. Use Chrome and you won’t have the problem anymore.

This is an ongoing problem in Safari, I posted about it a few weeks ago. I have been through every setting I can find and there are none that clear cookies when the browser closes. The only thing I have set regarding cookies is ‘Prevent cross site tracking’. I can’t see why that should affect Lingq.

I gave up and started using Chrome for Lingq. Annoying because I prefer Safari.

The issue with settings seems to appear on Safari only. Our developers are notified about this issue and we are looking for solution. Hopefully we will figure out why that happens.

Safari updated to Version 13 and the settings problem seems to have gone away. The echo on the text to speech problem is still there.

Great! This seems to have fixed it for me too. However, once I updated to Version 13, the lingq import extension no longer works.

Had to reinstall the extension, looks different but it still seems to work.

I tried this, but I currently log in via google, and the extension required log in information which I don’t have.

@zoran - any advice?

@davidrobinson You don’t have login information for your LingQ account? If so, please contact me on support(at)lingq.com and I’ll help you with that.
Or, here’s the link to new LingQ Safari Extension: Get the LingQ Importer - Safari extension!

It seems to have stopped working anyway. Probably needs an update to suit the new Safari version. Back to Chrome.

Will do,

I don’t think I do? I just connect using the ‘log in via gmail’ button. Ill email you to find out what my actual log in is though!