Why does it translate the course title to English when I put my cursor over it?

not sure why it does this, or why it’s good!

1 Like

LingQ will now use Google translate to translate titles to the language your user interface is set to. I used to add the English translation of the lesson’s title to the lesson description, but the new way is much more convenient and flexible. The basic idea is to make it easier for beginners to navigate the library, especially when dealing with a foreign script.


Can it be deactivated? It is very annoying when I have to select/copy the title (e.g. to google something about the book). I think it would be better if it was something optional or just a subtitle.


Since I am trying to learn the language, personally I would prefer to see titles in the actual language. I’m not a beginner and even if I were, I wouldn’t like. I find it annoying.


I don’t know if an option to disable this feature is planned, but you can try setting the interface language to your target language if it is supported. Mine is Chinese simplified and it works well for me.

1 Like

To turn it off, change this to your L2. (Found in Settings.)

Alternatively, it’s the same as changing the language code in the URL. Then you no longer see the translations for that language. Eg. “en” → “it”

Obviously, if you are learning multiple languages, you need to change it each time you switch languages.

I do work on multiple languages every single day so obviously that’s not very practical


It happens to me as well. This doesn’t make sense at all. Titles of courses should stay in the target language for each language, not changed in another. I want to see the titles of my imported books in the target language I import them not in any other interface language. Interface it is for functional purpose, nothing to do with courses or lessons.


Seems to have started a few days ago. Frankly, no matter what feature LingQ adds, some will like it some won’t. It would be great to be able to disable it. It doesn’t bother me as it only occurs if I mouse over a title. Since there is no reason to mouse over a title, it’s easy to avoid. If it helps newcomers, what’s the harm?

I just have to train myself to not over the mouse to anything before deciding to click it. This for every lesson and every course for each language, every day. Sure, I train myself for avoiding a lot of bugs and trying to reduce clicking as much as I can, this is just another thing to do.

Even more, I have the interface in English because many people prefer to have interfaces in English so to match other interfaces in many other programs but my native language is not English. So, it wouldn’t help these people either.

The option to chose would be definitely the best in this case, if this feature helps newcomers and doesn’t help everybody else.

Best option would be to choose the automatic translation of titles in this way:

  • leave unchanged for every language
  • chose the interface language
  • chose another language of choice

@davideroccato I’m just glad that I mainly use Android…

It’s not good. I’m sad it’s seems to have been a choice.

I have changed my interface language. It stops it but now I don’t understand the interface and all my bookmarks are still wrong.


Agree that it would be really, really helpful to make this an option. Honestly it’s annoying to have the target language titles and other details flashing to English just moving the mouse around. And the recommended fix of changing the interface language does not work because my target language is not an interface language option.

1 Like

This is a nuisance more than anything else and there definitely should be an option to disable this.


I agree here, I would very much prefer to disable (often poor) machine translations for my lesson uploads or library.

1 Like