When I edit a sentance, the sentence does not update

I edit a sentence and try to fix it. I click the save button then done. Usually a message appears “updating sentence” then the sentence updates. If it doesn’t appear, I know something went wrong so I do it again.

This was annoying but atleast after 2-3 tries it almost always worked.

This time it’s not working at all.

can you give us more details about your browser? are you using iOS?

This happens to me on chrome and opera on Win10 PC.

ok thanks, we will look into this.

Still having this issue. It’s worse now. I used to have to try maybe times, but I’ve been trying to edit something for a few minutes now.

I tried on 4 browsers, chrome, firefox, opera, edge.

Is there something wrong with my account?

Edit: and just as I post this, it works. LingQ has been pretty frustrating to work with recently.


I encountered a similar problem today:

“Edit lesson” is not working at all. The “replace all” function does not replace the words in question; nor does the lesson update when I adjust words individually, although the edit shows as saved. The only thing that does work is “adjust sentence” in sentence mode.

This is on Firefox, and in Persian. I do not know whether the problem only affects this language as I haven’t had occasion to edit in another language since encountering it.


Yes, the same thing is happening to me. I’ve tried Chrome, Opera and Safari and edits don’t save at all. Text just stays the same. I’m doing German.

Thanks for reporting, I asked our team to look into it again.


Same thing started happening to me today with Korean and in Chrome (and Safari) (using macOS, if that matters).

Usually, I see a yellow “saving” message (that switches to green “saved” text) over by the “view lesson” button in the edit lesson mode, but not anymore.

As @fabbol wrote below, the “Edit Sentence” feature seems to be the only way to edit sentences and get changes to save, at least as far as I can tell.

Morning 06/21/23 update: As @blotski wrote, it seems to be working again. I see the “saving” and “saved” indicators next to the “View Lesson” button I should be seeing.

Hi, the same is happening to me… When I try to edit nothing happens. Since yesterday, when I try to delete a Paragraph, i receive the message: “Index, this field is required”, but this never happened before.

Seems to be working alright again this morning 21.6.23. Thanks.

Still continuously having this issue. I only come back to post here when it’s particularly bad. Tried to edit the same sentence like 15 times. No luck.

Sorry to hear that. What browser are you using?

Still having this issue, same browser firefox. I didn’t both trying other browsers this time because all the other times I did, I had the same issue on all the other browsers.

No matter how many times I try to update, it won’t work. Usually waiting for a long period and coming back to it works.

Arggh, it’s so bad. 5 mins trying to edit it and still doesn’t work. Seemed to be alot better yesterday. I think I jinxed it by saying “just gotta wait long period”. Not THIS long though.

I should probably stop trying to improve content. Really bugs me though.

Alright, I’m still having issues. I can try reset my account from scratch to fix it. This issue pisses me off so much that I’m willing to do it. If this doesn’t fix the issue, can my account be restored?

I’d like to know before I attempt it.

Uhh… its never usually this long. Usually have to wait no more than 5 mins. I tried logging out and logging in serveral. I tried using Opera instead of firefox. I tried refreshing the page repeatedly. I don’t think theres any more information I can provide to help.

I don’t know if I’m the only one still having this issue. Unfortunately I did a yearly sub, so I’ll have to work around it. It’ll take awhile to get used to.

Anyways thanks, you can close this thread.

We will look into it again. Thanks for letting me know.