Uploaded audio replaced by TTS audio

I have a private course with a number of imported Chinese lessons, to which I am trying to add the audio. I use Firefox on PC to import the lessons and the audio, and want to use Android to review.

Every time I upload the audio for the lessons things seem to work at first, but as soon as I try to review the lessons from my Android phone the lesson audio has been replaced by the generated TTS. When I go back on the web version of Lingq on Firefox, the uploaded audio has disappeared from there too.

I have tried to upload the audio for this course twice now, which takes some time since it includes 37 lessons. Every time the audio gets replaced by the generated TTS. There is clearly a bug with the handling of lesson audio.

1 Like

I can’t seem to reproduce that. Can you please reach us on support(at)lingq.com and provide lesson URL and audio you are trying to upload? Thanks!

I sent the link and audio files to the support address.

In the meantime, I discovered that I can reproduce the bug if I navigate to the course page on Android, and tap on the button to download the audio for all lessons. In that case most lessons will have their audio replaced by the TTS versions (interestingly, there is at least one lesson where this bug is never triggered).

If I don’t use the option to pre-download the course, and just let the Android app download the audio automatically when I open a lesson, things seem to work as expected (so far).

I am having the same problem as well on the Android and web app. The audio from imported YT videos is now replaced by TTS when I click on the little headphones or play icon. The issue does not concern MP3 files that were added separately. The app has been experiencing bug after bug since the last update. Everything was working fine before Saturday’s update.

You’re not mixing up pressing “s” instead of “a” for audio (or is it vice versa)? One is TTS, the other the recorded audio.

Please fix this as this is a very annoying problem. The audio of all my imported YouTube videos has been replaced by TTS since last weekend’s update.

1 Like

@SeoulMate can you please give us more details what exactly you do when audio gets replaced? Are you also using app version when that happens or are you on web?

Hi Zoran,

After investigating further, I have identified the source of the problem. The videos in question were not “fully” imported into Lingq. I realised that because their duration didn’t match the duration of the videos on YouTube. As a result, the audio wasn’t properly imported, so TTS was “taking over” and the text was out of sync with the audio.

I have tried reimporting the videos and it’s working fine again.


This problem is still present. As per the original post when you attempt to download audio to an Android device the native audio will be “overridden” by TTS audio.

The normal sequence of events when this problem occurs is.
upload to lingq on PC
complete lessons on PC (with native audio)
at a later time attempt to add the lessons to a playlist on android
download lesson audio so that they will add to playlist
TTS audio replaces native audio

As an interim fix is there a way to prevent TTS audio being generated at all? I don’t ever want that so if I can turn it off and stop it replacing native content that would be the preference.

Does this also happen on the reader?

Once the lesson audio is replaced by the TTS audio through the above error, it is replaced across all LingQ devices (computer and phone)