Unable to select words (Chinese)

I’ve been using LingQ to learn Chinese for about a month now, and it has been working great until today. It seems that all words that are made up of 3 or more symbols are not showing up as blue, even though I have not marked them as “known”. I am even unable to manually highlight the word. This hasn’t been a problem in the past, so I’m not sure what I did to break it.
For example, “为什么” in part 2 of “Who is She?” was the first 3-symbol word I learned, and there was no problem. Today, I can’t even select it. I even skipped ahead to part 8 to find a 3-symbol word I haven’t come across yet, and I couldn’t select that one either. This happens in Chrome, Firefox, and on my android phone.
I noticed in another post that Alex asked someone to go into developer tools to try to identify the error, so I did that, and this is what came up when I tried to select “电子邮件” in part 5 of “Who is She?”:

Uncaught TypeError: Cannot read property ‘parentNode’ of undefined 5c55a7f4bc81.js:244f.Workdesk.Views.Reader.q.LingQUtils.StatefulView.extend.highlightPhrase 5c55a7f4bc81.js:244nrWrapper

Thanks in advance,

1 Like

It seems to have something to do with spacing, which means manual work for the uploader. If the spacing isn’t correct then 为 and 什么 will both be blue words (which they are individually) and you can mark them known or lingq them.

If you’ve already dealt with 为 and 什么 separately, or even if you haven’t yet, they will only show up as a blue word together if the spacing was done correctly. You may come across it in another lesson where 为什么 is blue even if they are already known or lingq’d separately.

In new lessons, I sometimes still have over 200 blue words and by the time I x-out all the falsely recognized words and mark known words as known, there may only be a dozen new words for me.

As for why you can’t manually highlight the word, perhaps choose to hide the spacing first (click the little gear at the top of the lesson page). Then see if you can highlight it.

Otherwise, maybe choose to manually import it as a vocabulary term on the vocab page.

I think you’re only other option would be to wait until it shows up properly recognized as a blue word in a future lesson.

1 Like

Thanks for the suggestions, but it doesn’t have anything to do with the spacing, since it had been working great for the past month until yesterday. I always choose to hide spacing, and if I choose to show spacing, it has no effect.
When “为什么” first came up, it was a blue, 3-symbol word, and when I clicked on it, the information about the word came up in the panel on the right. Now I cannot see the information for any word containing 3 or more symbols, even ones like “为什么” that I have already learned. For example, “电子邮件”, “女朋友”, and “说实话” are all unable to be selected. When I load the lesson page, these words show up in white (haven’t seen them before) and when I click on them, their information doesn’t show up on the right side panel. I am able to see their definition in Google Translate only if I include the words before and after them while highlighting.
Importing as a vocabulary term won’t have any effect, because “为什么” is already one of my vocab terms and I am still not able to select it.

1 Like

This does seem to be a problem. We are looking into it.

I’m having the same issue as you.