Unable to load dictionary in iOS apps

Hi, on my iPad and iPhone in the Lingq app when I select check dictionary very often I get an error message
“unable to load dictionary at this time”. It doesn’t happen all the time but certainly most of the time.
Instead, if I need to check a word I have to open a web window and do a google search. This limits my use of the app for creating links. On the PC there are no problems.


Hi Max,

Sorry to hear you’re having trouble with this! A few of questions for you:

  1. Would you let us know which dictionary you are using?
  2. If you try switching to another dictionary, does this occur as frequently?
  3. When this happens, are you connected to wifi or using a cellular network?

Thanks Alex.

  1. I’m using Google Translate
  2. I tried last night using other dictionaries (that I’d never used before) and I couldn’t get the problem to re-occur. But I only tested it for a short time.
  3. I’m connected to wifi normally but I’ve had the same problem whilst on 3G on my iPhone.

Last night it worked for some words and then randomly I get " the unable to load…" error.

OK, thanks for the additional information on this! I’ll pass this along to our development team and will let you know if we need anything further.

Just a heads up on this - we’ll be making a change in an upcoming version of the app that should hopefully fix this issue. In the meantime if you run into any other issues be sure to let us know!

Hi, just adding to this thread that the problem is still occurring with the new app. I referred to this in another post yesterday. I don’t know whether anyone else has had the problem. I can’t find another reference to it. Unless it’s something unique in my set up? But it does happen on both iPad and iPhone (running ios7).

Sorry, the newest version includes a few more fixes than we originally thought it might, so we’re just working on finalizing things now. When the new version is up, please let us know if you’re still experiencing this issue.

Looks like the problem is fixed in the latest update! Thank you.