[ui bug] "show translations" : "Do you want to regenerate all your translations?"

The option “show translation” is used to be a good option to show the translation and then the same option to hide translation.

Now, if I click “show translation” I get a question: do you want to AI generate translations? yes or no?

Are you guys kidding? Do you have five year olds making this stuff up? Are you too stingy on interface options to make “generate translations” a separate option within “edit lesson”?

So, every time I do “show translation” I have to say “No, I don’t want to generate translations!”.

Please sanitize this option and if possible give “show translation” a keyboard shortcut.
Also, I would appreciate real feedback like ETA, if and when it is going to be corrected, and when it finally is corrected. Thank you.

1 Like

Thanks for your feedback, I’ll check this with our team.

Hi @gbonnema !
The suggestion to generate the full translation should not appear if the translation already exists.
Is this happening to you in all lessons or certain ones? (please, provide a link to such a lesson)

The option presents itself in all lessons that I know of, but in light of your remark, it might not show when all lines are translated. I did not try that, because that is not the point.

The point is that a low frequency option “generate translations” does not belong in the bottom of an option that just means to show translation, which is normally a higher frequency. The use of show translation is very different from generating.

I would have expected such an option in the “edit lesson” part where you can regenerate time stamps, and additionally you can choose to generate translations. That would make sense. HIding it in “show translations” is just bad craftmanship.

Did I answer your query sufficiently?

Thank you for your detailed answer and for pointing out this matter. We will pay attention to it.
As for the presence of this feature in the Lesson Editor - it is placed there too, as can be seen in the screenshot.

1 Like