Trouble with App on Iphone

For a couple of weeks now, my LingQ (updated) app is not seeing that my phone is connected to the internet. I’m clearly connected to the internet through wi-fi at home, but it doesn’t recognize it and hence will not update my lessons. Can you give me some guidance. I just deleted the app and reloaded it from the app store, and the same issue exists. C

@CTaylor - Does it work when it is connected via 3G or is that also giving you trouble? Also, when connected to wifi are you able to open Safari and load the site?

(1) I think it was working on 3G, but it was blowing out my data download limits every month.

(2) Yes, I can open and log in to the lingq site on my iPhone through Safari just fine.

@CTaylor - OK, so we at least know that your wifi network is working :slight_smile: What is the app showing? Is it showing the “No network connection” screen, where it says “Only lessons which have been…”? If you turn on airplane mode, open the app, then turn on wifi and switch back to the app, does it stay in the offline view?


When I’m trying to connect to 3G it shows “no network connection”. Now when I go to airplane mode it says "“there are no lessons in this language” or something like that. When I am connected through ATT cellular, I can download lessons and listen to them. Yesterday I did that, yet today I can’t go into airplane mode and get my lessons that I listened to yesterday through the cellular network. And again I haven’t been able to download and listen to lessons on wifi because of the “no network connection”.


Bottom line in this is my iPhone app still refuses to see that my phone is connected to wifi and claims there are no lessons that can be downloaded. This doesn’t happen on the iPad. I’ve tried clearing the cache, reloading the app, turning airplane mode off and on etc. No lessons will download.

@CTaylor - Thanks for the additional information on this issue. We do have it in our list and hopefully will have a chance to look into it soon. Please note that we aren’t having any other reports of this issue so we can’t promise an immediate fix for it.

@CTaylor- Make sure in the settings ‘Synch Playlists Via 3G’ is turned on.

@CTaylor, I’m the developer working on iLingQ. Could you give me a little more information?

What device and iOS version do you have?

You said:
When I’m trying to connect to 3G it shows “no network connection”. Now when I go to airplane mode it says “there are no lessons in this language” or something like that. When I am connected through ATT cellular, I can download lessons and listen to them.

You mentioned both 3G and ATT Cellular here. Are they different somehow? When you are on 3G does it show that message and then still allow you to download?

If you delete the app and reinstall, can you log in over wifi? Does the avatar show in the background over wifi? How about the language flags at the top of the app? I assume that the list of lessons is not even downloading. But if it is, and you just can’t open the lessons, can you add a lesson to a playlist? Does the audio download on the playlists tab then?

I just saw your response.

I now can’t get lessons to download on either my ipad or iPhone. Neither wifi nor cellular works. This is only a problem for spanish, not french. I have no idea why.

I have the newest iphone and the newest OS. I have the newest OS on both devices that I downloaded within the past couple of weeks. It could be linked to that.

As I’ve mentioned. I’ve deleted the app and reinstalled.

The lessons try to download. There is a “loading” indication and then a window comes up saying I have no lessons to download.

I see no avatar.

@CTaylor - That latest version of iLingQ was just published on the app store. Take a look and see if it resolves your issue. Let us know.

Okay, after using the latest version for about a week now, I have good news and bad news. The good is that it seems like the program is downloading my latest lessons over wi-fi, without the need for cellular. The bad news is when I take the following steps, it doesn’t work:

(a) I open the lessons over wifi that I want to work on; I see that it downloads from 0 to 100%

(b) I then shut down the app

(c) I then go to airplane mode

(d) I then open the app

What happens next is that the old set of lessons load up and are available. So I pull the screen down and there is a message at the top that says “Loading. . . Last Updated 10/17/2013 11:11 AM”). But it is now 11:21 aM and nothing has happened. In fact, actually started step (d) at 11:01 AM. So twenty minutes and nothing has happened yet. The files I want to work on are indeed large, but it took little time for step (a).

Appreciate your thoughts and comments/guidance.


@CTaylor, I’m glad your wifi/3g issue has sorted itself out!

It’s certainly a bug that the reload label stays in airplane mode. I’ve fixed this for the next version.

However, I’m not clear on why you’re reloading while in offline mode. Are you saying that the most recent lessons that you downloaded are not showing up when you reenter the app? I have one suggestion for you if that is the case. After you get the lessons you want downloaded and before going offline, try changing a lingq status from, for example, 1 to 2 to 1. This should trigger the app to save it’s data. Please be sure to let me know if that does fix the problem as it will help me track down a way of permanently fixing it.

Also, you don’t have to exit the app to turn on airplane mode anymore. What happens if you activate control center while within the app? Do your lessons show up then?

Hey guys, mind if I add an issue I have noticed? I am a new user of the app, so maybe I have a setting wrong?

I have listened to a certain 6 minute long lesson 23 times. The app shows that I have listened for these 23 times, but it marks this as 0 minutes listened.

I thought the way it worked was (a) you load the lessons while online and download a few (by choosing them and making them go from 0-100 percent); (b) I leave my house and I want to listen to one of the lessons I loaded; I open up the app, and it is suppose to reload the ones that I just downloaded online, no?

Also in addition to my last message, can you tell me what it means to “activate control center while within the app”. Thanks.

@CTaylor, you are right that is what is supposed to happen. When I say “reload” I’m specifically referring to pulling down the lesson list. However, in offline mode you don’t need to pull the list down as there is no internet connection to reload the lessons from.

Also, the lesson audio and the lesson text and lingqs are managed separately. Even if the audio doesn’t download 100% you should still be able to access the lesson text offline if you have opened it once. I understood the issue that you are having to be that you can’t open the lesson text because it is not appearing in the lesson list. Is that correct?

Here’s an introduction to Control Center. It’s a nice new feature of iOS 7.

@djvlbass - What about on the site? Does the audio have a duration showing? Does the counter total properly?

I am having a small problem with the app. Sometimes when I am reading Chinese texts on the app, LingQed words are shown as if they were known, or ignored. (i.e. they are not shown as LingQed). For example, see this image

After the 2, the characters 和 and 子 appear. On the website, these are both separate LingQs, but on the app, they are not LingQed at all. I am finding this a lot. Maybe one of two words per lesson.

Also, just as a suggestion, it would be nice if when playing the audio for an entire playlist the audio would automatically repeat when it gets to the end of the playlist. I keep making playlists with ten or so 30 second lessons and having the keep getting the phone out to restart the audio when I just want it to go round. While doing the dishes, this is a problem because I need to dry my hands first.


@ColinJohnstone - That image doesn’t seem to work for me. Can you try posting it again? Regarding playlists, have you tried clicking the continuous play button at the bottom of the playlist screen? The button with the circular arrow icon on it. I believe this should do what you want.