Translated exchange add the original text

There was an exchange request for a translation from English into French from:

You find the request here:

The import of the lesson added the original text (in English) instead of the translation to my French slot. I would expect to have the translation in the text, and the original text in the translation tab.

@Vera - We assumed the translation would work more in the opposite direction meaning from your target language to your own language. When submitting a request you indicate what language the text is in and what language translation you want. This tells the system how to import it. Therefore when importing a text that has been translated, it would be imported into your indicated language slot with the translation in the translation area. We did not count on users asking for native language text to be translated into your target language. For now, you will have to copy and paste the text into the other language slot and set it up the way you would like. We will have to see what ends up being the most common direction for the translation action since the import button can only be set up one way or the other.

What you assume is ok but there is a bug. I hope I can make it more clear:

In this case djvlbass asked for a translation from English into French. His request under Login - LingQ looks perfect for me. He wrote an English text and asked for a translation and a recording into French. It was done by Serge.

I’ve imported the lesson. It went into my French slot. So far this was great. But the original text (remember: in English) from djvlbass went into the lesson text (remember: a French lesson), and the translation of Serge (remember: in French) went into the translation notes. I think in general what you do is fine but you mixed up which text has to go to which place.

The point is that the original text was submitted as French which means that it is imported as a French lesson. In fact, it was in English but our system can’t know that. The translated text is designed to be added as a translation and not as the lesson text. The original should have been submitted as English since that is what it is but when imported still wouldn’t have done what you wanted which is to have the translated text appear as the lesson text and the original text appear as the translation. It is all a little confusing! Not sure we can automate this to handle every situation unfortunately. Perhaps, we need a way to move a lesson from one language to another when accidentally added to the wrong language…

I admit that I cannot follow you, but I think something has to be done to work this better out. If someone whishes a translation you have to know the original language and the target language. And you have to know which language the user wants to learn. So is he learning English or French in this case. It sounds tricky … But I’m sure you’ll find a solution.

In general I think the part where you make the request for the exchange should be pointed out much better, and more separated from the listing below.

@VeraI -

What djvlbass did was put French for both of these, instead of “English” for the top and “French” for the bottom. This is why the translation doesn’t import properly.

Thank you. That makes it clearer to me. There seems to be a need for the option to correct this.