There was an error importing this file. Please ensure all digital protection has been removed

I have problem to add ebook.
I got message: " There was an error importing this file. Please ensure all digital protection has been removed.
I added more book in linq, but now I have problem.
I have Calibre, installed drm remove plugin, but still cannot add ebook.

Any advice how to do that?


I converted ebook to .txt format ir tried to import that file.
Doesn’t work.

1 Like

Me too . I tried to add ebooks but this problem happens.
It is not possible to add that though i removed drm .

I hope those guys will fix that, because I almost finished HP4 :slight_smile:

What file format does your file have before you put it into calibre? I got the same error message when removing drm from a pdf, but the epub-version of the same book worked fine. Perhaps you can download another file format from your source, or if that isn’t possible, try changing output format.

Thanks for advising me about that, but I did this methods you talked. so I tried to add e-books which i hit success formerly but now I can’t add that either LOOL I don’t know why is not worked.

I used the add ebook recently and I got the error message. I think I got around it by opening the PDF in Word and saving it as a Word document then used the add ebook again.

1 Like

I cannot add ebook, I was added before too … :frowning:

I am having the same problem. I have the third harry potter book (purchased DRM free from the Pottermore website) and i keep getting the same message.

I purchased the second HP book last fall and had no trouble loading it to LingQ. Has there been a change to how ePub files are handled?

I’m having the same issue with standard, DRM-free PDFs, the likes of which I had been seamlessly importing only last week. I fear something has changed behind the scenes which has caused this… it’s frustrating because the content is the learning material for my German lessons

I got an answer from support, they are working on that and everything will be good.
I hope :slight_smile:

1 Like

I hope everything will be good too :D!

1 Like

This isn’t the first time this problem has happened. We deserve an answer from support on when this problem will be corrected.

I received a message that it is fixed. I just tried to load an ePub and it appears to be working now. You may want to try again.

yes. it is working now. :slight_smile:
thanks support, even if you have not been in this discussion. :slight_smile:

1 Like

I’m having the same problem.