Text selection is STILL not working

This issue has been reported a couple of weeks ago and apparently a fix had been pushed. I don’t know if there’s been further update that messed things up again or the original one didn’t fix anything, but selecting text is still working very arbitrarily.

When I say select text I mean a selection during reading that triggers the meaning/dictionary lookup. A lot of the time when you select a phrase the UI doesn’t react and you have to select it again and again, and eventually it ends up working. Clicking on single words works fine.

I don’t understand why this isn’t the #1 priority considering how important this “feature” is for the entire experience of using LingQ, but it should be.

This is happening on the latest version of Chrome / web version.


We will investigate the issue. Thanks for reporting.

Hi Gigusek,

Can you provide more details? Does it happen in a specific language or lesson? Are you selecting phrases by clicking Word 1 and then shift + clicking Word 2?

I think this is the same issue as found here: Text Selection - Language Forum @ LingQ

I have been having this same issue for weeks. I’m sure you are very busy with other bug fixes, but is there any chance this could be prioritized? It’s making using the UI very tedious.

1 Like

I’m not using shift, just the regular selecting with mouse by dragging the cursor until the end of selection. It’s not a language/lesson specific as far as I know. I’ve played around with it and managed to narrow down the problem, and under these circumstances the selection never triggers the dictionary look-up:

  1. Click on a single word.
  2. Select a phrase that contains that single word (if done using shift it works fine).

When done like this, it’s never going to trigger the dictionary lookup. If you select 2 or more words in the 1st step, or select a phrase that doesn’t include the previously selected word then the problem doesn’t occur. Could be that there are also other ways to trigger the problem but this one has 100% success rate.

not the commenter but will add,I am having this issue running on the current version of safari. Any lesson i am in.

I try to highlight a phrase, it highlights the words but it doesn’t activate a translation popup

the other thing is when highlighting a single word, i click off it but it doesn’t click off properly and if I want to return to the words I have to click around before going back to it.

Thanks Robert, I was able to reproduce that issue and reported it to our developers.

1 Like

Unfortunately I still can’t reproduce this particular issue. No matter what I do I am able to select a phrase and see the translation appear.

I also experience this issue, with Spanish & Japanese. I’m using MacOs with Chrome. I didn’t feel it was a major problem, but it is an annoyance, and did not happen prior to a few weeks ago.

Well, I don’t know what to tell you, but the problem is still there and happens in different courses/languages and different browsers (Chrome, Firefox and Edge) when done the way I described. I’ve also noticed that if the word selected in #1 is in the middle of the selection in #2 the dictionary does work, but if it’s in the beginning or end it doesn’t.

As you can imagine it’s very tedious when your process while reading is to translate the unknown word first and then translate the entire phrase/sentence, since a lot of the time you’ll have to force it to work.

Is this close to being fixed?

This should actually be fixed. Any chance you can take a video of the issue and send it to support(at)lingq.com? That would be great. Thanks!

I think I’ve found a way to reliably reproduce the bug. You need to have a word selected and then try to select a phrase releasing the mouse button on the word that you had selected.


Exactly what I meant!

On a side note, what have you used to record this? I was also going to make a gif, using ShareX, but unfortunately my settings must be messed up because the file would always come out as a non-working mp4 and I’d get a bunch of errors in the console :stuck_out_tongue:

This is consistent with what I have seen as well.

still not working for me (Chinese, Chrome) 6th Jan 2023