Text jumping around while reading

Has anyone else noticed lately that the text is increasingly jumping around as you move through the blue words? For example, I’ll be reading and clicking through words, either hitting enter to make a lingq or moving along if I know the word, and as I select a word it make the line slightly longer, so a word gets pushed to the next line and the whole page shifts around. As soon as I click forward to the next word it jumps around again. This makes extended reading incredibly frustrating and tiring.

I have never had this happen before the past few days. I did recently switch to using Chrome instead of Safari, because of the other issues I’ve discussed on here with Safari that the LingQ team couldn’t fix. But I didn’t notice this new problem right after that switch. It has just occurred the past few days.


I am experiencing the same problem! It started about 3 days ago, same issue.


It happened for me a few days ago shortly after I updated Chrome (maybe just a coincidence).

1 Like

Coincidence. I am using this on firefox and the same problem exists.


This problem seems to actually be getting worse. Today, I’ve been noticing that text is jumping around even in paragraphs I’m not currently working on. I may be selecting words in the second paragraph on the page, which might not be moving at all, and the one above it will be jumping all over the place. Then, on the next page the one I’m trying to read keeps shifting around. This is practically giving me headaches. I can’t use the site for more than a few minutes at a time.

This needs to be a top priority for the LingQ team. Please drop everything and fix this first. The settings problem was annoying, but at least it could be corrected once on each visit to the site. The text moving around makes using the site at all very difficult.


Agree. It’s getting bloody annoying. It’s hard enough to read in a foreign language. I’m doing most of my reading offline until this is fixed.

1 Like

Thanks for letting us know about it. We will get it fixed.

1 Like

Yes, also having this issue. I find that the text to speech doesn’t work well in safari, so I usually use chrome. and it is a quite annoying to have a work you click jump down to the next line.

I also emailed LingQ support about this issue, to make sure they saw this thread (and Zoran commented in response, as you can see). But, they asked me to record it happening. Does anyone have recording software on their computers already, who could do this easily? I have never done this. I will get the software and do it if I need to, but I am sure someone already has it and knows how to use it.

This demonstrates the problem, when it happens and when it doesn’t.

This on some pages.

But wait, there is more:

Thanks a lot everyone, videos are really helpful. We will get it fixed!


any updates?

We hope to push a fix for this issue within a next day or two. Thanks for your patience!


Is this supposed to be fixed now because I’m still getting it.

1 Like

Hmm, thanks for letting me know. I’ll check with our team.

Quick question everyone, which OS are you using?

Windows 10 on Chrome 75.0.3770.100

im pretty sure this is because of the extra scrollbar on the right panel for the translations, if you zoom out, text is smaller so more can fit, so this scrollbar will not appear for all words (depends on how much text the translations take)

here is a screenshot of the scrollbar ( in blue)

by zooming in, the scrollbar appears for some words automatically, and the right panel seems to move to the left slightly more often, and causing this “jumping” effect

edit: just checked the video posted by miscology and the same thing happens there, it only jumps because of the scrollbar on the right panel

1 Like

This should be fixed now. Can you guys please check and let me know if you still have the same problem?

1 Like

So far so good, thanks!

1 Like