Submit Writing does not work

When I click the Submit button, the system will not respond.

Have you tried refreshing your browser. Everything seems fine for me. Please make sure you have a corrector selected.

Mark, I had trouble submitting writing back in February and also yesterday. The correct tutor received the writing this time, but I had to try two or three times to send it.

RQ - Can you explain exactly what problems you had. And, can you tell me what browser and version you are using?

When I clicked the Submit button, the system did not respond. After several minutes, I saw the result “None, None” on the page. I tried again, and it finally worked, but the failed one was there in the list on the page. I deleted the title and the writing, which is now treated as a blank draft in the list.

Before I clicked the button, I had been able to select a collector, although the server’s response was very slow. It took me a few minutes to get the list of the tutors.

(I hope this posting does not face any trouble.)

It worked.

My writing is to be collected and corrected by the tutor whom I selected.