The new version Lingq 5.0 is available for more than a week. I like some traits of a new version: the design is more colorful, there is a more user-friendly interface. The idea of shelves is interesting and gives the users the better opportunity to find and to choose a proper lesson or podcast.
But there are also some things that irritate me.
For example, there was a good option in the former version – a ‘classic view’ when we could see the whole text and work with it in a go.
The text devided to many paragraphes is good for a beginner level when a student has a lot of new words. But I have only 2-3 new words in the whole text, it’s annoying slowly to go from page to page and to do many abundant clicks. Is there such an opportunity? I couldn’t find it.
As for a teacher and a provider, I’m also very interested in importing my new lessons and texts. First two days I just couldn’t import new podcasts. Now I can but it takes me twice as much time as before.
In the former version I firstly chose the course, it appeared in the first line at the top of the page, and automatically I received a proper level, an image that was the same for the whole course.
After pasting and saving the text I saw on the right side all texts from this course and could give a proper number for a new text.
Then I added the audio file, tags,chose the provider and clicked: Save and open – and the shared text appeared, I checked them – that’s all.
Now I tried to choose the course – but no course appeared in the first line or anywhere else.
Then I pasted the text and after clicking ‘save and generate lesson’ the text was divided to many paragraphs – I needn’t this option for importing the text, this sudden division only irritates me.
After that I added the audio file, but also with some additional clicks, not for one click as before.
Then I tried to share a new podcast but I saw the inscription: ‘you have to add an image’ – it means that a general image for the whole course doesn’t work, I had again to spend more time in searching and pasting the image.
But even after that I can’t share the text because I have another inscription: ‘the texts added by quick import can’t be shared, they are used only as private lessons’.
So I must return to the list of courses (though I did it as the first step), scroll all courses again and add the proper course.
Only after all these many additional clicks I was able finally to share my text.
And the last, but not less important thing:
The whole week I receive a lot of notifications that somebody edited my lessons. Sometimes I tried to check edited texts but I couln’t see any changings. Somebody answered me that it could be autiomatically if the students used the option ‘Sentence view’. I don’t know but such spam letters irritate me, last two days I have more than 150 such notifications that I should manually delete – it takes 30 minutes of my time every day! How can I reject such sort of letters without declining of other notifications, for example, the notifications of booking my conversations?


Hi Evgueny,

  1. Regarding the Full-Text mode, it is no longer available (the same goes for the Classic view), but you can still see and read the whole text in the Listening mode under the audio player. For now, on the website, a lesson needs to have audio available to activate this mode, but we will soon make changes there.

  2. Regarding the import, we will look into this and see if we can improve the flow.

  3. Edited Lessons notifications are a bug, and we are investigating what is triggering these emails. We will get it sorted out. Sorry about that!