Show/Hide Spacing in Asian Languages

We just pushed an update that allows you to show or hide the spacing in Japanese and Chinese texts. I know some of you were not happy with the spacing introduced by our word splitter. Especially, you intermediate and advanced learners can now simply hide the spacing. The words are still split in the same places, however.

Thank you very-very-very much!
But it seems lingqing phrases does not work now.
When I highlight a phrase, first of all it takes several seconds for system to highlight this phrase with blue. Then I hover the blue selection and po-up window does not appear at all.

Forget to mention: I experience this both on Japanese and Russian.

You’re right. We’ll look into that.

Now it works fine :slight_smile: Thank you, members of LingQ team!

Excellent! Thank you for the functionality. Now the texts are more comfortable to read.

Aa :slight_smile: It is the problem with my home PC… At work phrase lingqing works fine, and at home it does not work…

phrase LingQing isn’t working for me (FF 3)

Yup, looks like a problem there Ed.

yes… I upgraded my browser, but phrase lingqing still does not work. But I did lingq phrases today at work. It drives me crazy!

This is great news! So with this new functionality, when uploading material, do we need to enter spaces between Chinese and Japanese words for the lingQ system to still recognize the individual words? I’m not clear if the upgrade just “virtually” removes the spaces. making them invisible, or if the system can actually read the individual words without spaces between them. Thanks.

Well, a few months ago we implemented automatic splitting of Asian texts so you no longer have to put spaces in your texts. The splitter, however, put spaces between all words which made the text less authentic. We have now added an option to hide the spacing but the word splits remain which allows the system to identify words.

Sorry to bump an old thread, but I was wondering whether it’s possible for the system to display a text exactly as it is written? I have imported a transcript, but some words such as 社會 are separated by the system as 社 會, despite being together, without spaces in the original transcript that I pasted in. If I hide the spaces, the whole sentence is then joined together, covered in blue. Is there any way around this? Oddly enough, the very same text which was already in the library in simplified character format (I imported a traditional conversion) is fine. I’ll fiddle about and see if I can fix this myself, and if I find a solution I’ll post it here!

Although I would like to use LingQ for Chinese more, I have still big problems with LingQ’s word splitting algorithm (doesn’t work properly in traditional Chinese!) and respecting the spaces that I inserted (it makes its own wrong decisions!). Would it be so difficult to switch off the splitting algorithm as an user option and use my “words” divided by spaces? The splitting algorithm works quite well with simplified characters, but not at all with traditional characters…

Ah, that explains why the original transcript was fine!

Thank you very much for this functionality!

Given all the things we have on our todo list, I doubt that we will refining the Chinese page for now. Sorry. However, I suggest you put it on the getsatisfaction wish list.

See forum thread for more information

One request, whoever, to whomever is putting in the traditional characters into the Hint. Please put this at the end of the Hint, since putting it at the front of the hint pushes the meaning or translation off the User Hint space in the pop up.