Sentence mode doesn't respect the playback speed setting

When I’m listening to a challenging story I sometimes set the playback speed to be a bit slower.
It would be nice if the play button in ‘Sentence View’ respected this setting. It always seems to play at full speed.

Thanks for your feedback and suggestion. We’ll look into it and see what we can do.