Saving when editing

I imported a clip from YouTube, but had to edit the captions so the time stamps were off. The auto-generate feature didn’t work, so I am editing the time stamps one by one from the “Clips” tab. But there’s no save button on this tab, so I’ve been making edits, going to the “Title & Text” tab and then hitting save.

This works most of the time, but sometimes it just doesn’t save the edits I made. I just tried to save the same ones three times, and it did not save at all. Because it’s timestamps, it’s very time-consuming to do, so I really want to make sure it saves when I make edits. Is there a better way to be doing this?

Sometimes it just takes a while for the auto-generate function to work. I suspect that when you save the text and audio for the first time, it starts analysing the audio in the background, but needs time to run the algorithm, and will still let you study the lesson in the meantime. May be worth trying to save the text and audio and then coming back half an hour later and seeing if the auto-generate timestamps button has appeared.

I just reposted the same video (because I didn’t want to lose the timestamps I’ve manually added the first time), waited an hour, and hit auto-generate timestamps. They are about 40% correct, so still would require a hue amount of editing.

My question, though, is about how to save the timestamps once I have edited them. It’s incredibly time consuming to figure out 10 of them, save it, and then find that the save didn’t “stick.” There’s no save button on the “Clips” tab so I’m not sure exactly how it’s supposed to work.

The general Save button is on the main edit page. So any changes you made on other tabs (including the Clips) will be saved if you click the Save button on the main page. Are you sure changes you made weren’t saved? Did you get a confirmation message that changes were saved successfully?

Have you used the ‘show/hide sentences’ button on the left hand side? That brings the timestamps up in red in the text of the lesson, and you can edit them there, or indeed delete them (though in order to get rid of the red marker entirely, I find you need to delete and then re-type the last character, usually a full stop, of the sentence before), or create new ones by positioning the cursor where you want one and clicking the ‘Mark end of sentence’ button, which should hopefully scroll down the screen with you. You can then just scroll to the bottom and click save.

Yes, every time I save I get the green bar at the top saying “Content has been saved”. But then when I flip back to the Clips tab, some of the timestamp edits have reverted to what they were before I saved them. I cannot figure out any pattern to why some save and some don’t. Sometimes I will do 10 in a row and the first 3 save, the next 2 don’t, and the next 5 do. And then when I edit them a second time, usually they save. At first I thought I was going crazy, but then I had one that didn’t save four times in a row so I am completely sure. In that instance, that was the only timestamp I was editing and I couldn’t get it to save at all, so I finally gave up and posted this.

When I edit the timestamps in this screen, it doesn’t register the save. I just tried it on the same line several times, and couldn’t understand why the clip was still playing in the wrong place because the red timestamp said the correct time. When I switched back to the ‘Clips’ tab, the timestamp had not been updated, despite me having saved it three times.