Rooster Master LingQ - The Ultimate LingQ Enhancement Tool

Beautifly done!

Thank you!!! :smiley:

Looks like it is highlighting and showing the wrong line, ill fix that soon.

edit: fixed! Update in the drive.

1 Like

Oh wow! Good catch! Thanks!

Also, can you add a scroll to the translation box for translations (and the extra translation box) that are a bit longer but still highlighted:

Note: Sometimes, the human translation (for more complex texts) has more than one sentence in the translated language that explains that single sentence in the target language.

In this case, Korean has a translation that is more than one sentence in the English translation to explain it.

The idea I was thinking of was that the manual scroll would operate within the boundaries of the highlighted text. After the user scrolls to the bottom of the highlighted text, the manual scroll ability would stop.

Edit: If anyone has a similar experience to the one shown above — it means that part of you can't see all of your highlighted text in reader mode using Rooster Reader:
  1. Navigate to your control popup (the one with all the selections for the popups in reader mode):

Screenshot 2023-10-01 at 07.19.04

  1. Click on Font Settings:

Click Font Settings Rooster Reader

  1. And adjust your zoom for the font you are using:


1 Like

I understand the use case but this is a bit tedious to implement.

You can use the Font settings to reduce the size of long sentences if required.

1 Like

You’re brilliant!!

This is exactly what I needed to do!

:exploding_head: I can’t believe I didn’t think of this.


1 Like

Hey @roosterburton,

This is how the Show LingQs shows up for me (in Rooster Master LingQ) after I click it:

Note: Maybe the Observer lite and Known words sections are blank here? My version does not label them, but based on your pictures and context, it looks like the middle two boxes show up for me: New words and LingQed words?

Is the Rooster Observer part having similar issues to before? Or am I missing something?


P.S./Edit": Minor note, my selections in the main control panel here show up a little off-center, and I just wanted to report it in case it was something you wanted to know:

It should work like New/LingQed/Known/Ignore on regular view. Observer LITE is just for new words.

Edit: I noticed the headers are there in your screenshot just very dim!

I’ll figure out a better solution to display these buttons

1 Like

Edit 2: The missing columns are resolved. @roosterburton cleared it up quickly! :smiley:

I pulled it up in a different lesson, and it shows up properly:

But in that same lesson, I checked at first, it still shows up like this:

Note: There are blue LingQs present in both lessons, but the one missing the results (second picture in this reply) has fewer blue LingQs.

No section labels, though:

Edit: This is an image with LingQ set to dark mode. Headings display correctly when LingQ is set to light mode.

I can just keep that in mind if it doesn’t display in a particular lesson.

1 Like

Interesting. You can help me by doing a couple things regarding this.

First open that lesson that isnt displaying correctly here. Saving and sending that data file to me will be helpful.

Another thing you can do is report any console errors.

To open the Console, press F12 / Ctrl+Shift+J (Windows, Linux) or Command+Option+J (macOS).

Click the trash can first then open the Observer display and post a screenshot of the log

I can see the labels in your pic! I’ll change the color slightly to make it show better

1 Like

:exploding_head: Omg! I see it in white, faintly, in that pic, I didn’t even notice! Thanks!

Edit: I just realized it’s because I set LingQ to dark mode. The headings are fine when LingQ is set to light mode:

1 Like

Can we get a resizable container for the dictionaries?

Seems like that might be my “Close” button for that window? (I just guessed and clicked on it and it closed the window, lol)

Like on the other windows?

1 Like

I’ll have a look at this entire menu shortly



1 Like

I’m most interested in seeing chosen statistics live or every time I move to another sentence.
•Words read today
•Words read overall
•Maybe new words today

This is already in HotKeys. New words today I could add.


1 Like

Perfect! Thank you!! :heart_eyes:

Tried this today! It works great!

Screenshot 2023-10-12 at 15.22.52

Great addition!

1 Like

@roosterburton, I’m still encountering the offset text:

Is the Rooster Reader accounting for the timestamp time listed for the title of the lesson?

1 Like

Thanks for the report. Just made a fix for the offset on the replacement mode.

Good to know. I need to make a small patch to it so it doesn’t send all the words in 0.5 secs

1 Like

Yes, thank you! This seems to have fixed it. It’s nice and synced!:


Added Language Reactor as a Auto LingQ Method. (This method fetches gpt/machine learning results for each queried word and applies the highest confidence result. Also applies grammar tags.



A patch that deserves its own post. Google Translate has been added as an alternative translation source. This method opens the google translate webpage in a new tab and continuously posts your lesson text one line at a time collating the translations. They are then sent to LingQ as a bundle. Progress is displayed as a percentage and translations are visible in the console before being sent to LingQ.

for 1.50
Added Google Translate as a secondary lesson translate option. (LingQ uses DeepL as their translation method. This translation is slower and is prone to breaking but can be a good alternative for some languages)
Fix for hotkeys propagation on edit sentence (Reader view)

1 Like