In the last time, I receive mostly requests for English. My native language is German, and earlier, I received only requests for German.

Why is that the case?

Hi Irene,
Be sure to select German as your Exchange Requests and Conversation Requests language on the Settings page (Login - LingQ) and you will receive requests for German.