Quick Import doesn't work

So today I’ve been trying to import news articles in japanese and german, but the Firefox plugin does nothing. It gives me the “Import complete. Open Lesson”-window, but clicking that only directs me to the LingQ library. I double-checked from the library and I can’t find the imported articles anywhere.

If it matters, here are the articles I’ve tried to import (zero problems with these sites before today):

Sorry to hear that. Do you have the latest extension version installed? If so, can you please logout/login back to the extension and let me know if that helps? Thanks!

I have same problem as nimotsu. Quick Import works for ebooks, but does not work with Firefox Extension. The popup says it has imported the website and the Open Lesson button is active, but it doesn’t open the lesson and the lesson is not in the LingQ list of lessons. Also there is no green pop up verifying the lesson has been imported. I updated the extension with no change. I have also logged out and logged back in, cleared the browser cache and rebooted the system. All to no avail.

My subscription updated for another year yesterday if that has anything to do with it.

Logged out and made sure the add-on was up to date, but that didn’t fix the issue. Then I tried importing on Chrome, which worked flawlessly. So probably a Firefox issue?

Good tip. I’ll use that until the problem is fixed. I think the firefox extension was updated on 3/21. That’s the last day it worked for me. The main thing I do with LingQ is import news and magazine articles so this is a major issue for me. Using chrome temporarily will make it easier. Thanks again, nimotsu.

1 Like

Thanks, we will investigate the issue.


The issue has been fixed. Please update the extension to the latest 2.2.11 version. Thanks!


Thanks for the speedy fix. Works fine. Updated automatically.