Problems with the software

The system seems to freeze up rather consistently when creating Linqs with the the Enter button. I have to reload the page or move onto another lesson and return. At least one time per lesson I would guess.

The K button isn’t reliable either.

Often when I “search dictionary” because the enter button won’t let me create a lingq, the hints that are already there get erased and I’m forced to check the dictionary and retype my own hint.

When trying to clean up the library by moving lessons to “archive” … some won’t move. I would like to have a library with lessons I want to learn, not full of stuff that is of no interest to me. Not all lessons are created equally. On this note, I think it would be wonderful if there was a “general library” from which you draw resources into “my library” from which you draw lessons that are stored in “my lessons” that can then be archived as “completed” or “semi-completed” etc…and properly rated for future users. Sometimes it is only after you study a lesson that you realize how useful a lesson really is. Snap decisions can cause roses to get given too soon, or roses not to be given when they really should be given.

And while I am at it, for Korean especially, is there not a way to be able to have a third color to be able to identify grammar patterns? So that the grammar patterns show up, regardless if different words are being used. Quite often these patterns are so similar to one another that it takes extra effort to learn them all. All the 는s 지s 을s 다고s etc…

Thank you!

Would you let us know which browser you’re using? I wonder if the same freezing issue is happening in other browsers as well. I haven’t noticed any issues and we haven’t had any reports on the lesson page freezing up, so a little more information would be helpful in figuring out what may be causing this.

I’m not sure that I understand the third issue with “Search dictionary”. On the blue pane, you’ll see user hints, a Google Translate translation, and a button to search the dictionary. When you click “Search dictionary” it means you don’t want any of the hints that are displayed on the blue pane and instead want to find your own. If you want to see these hints again after you’ve clicked “Search dictionary” you can click on the “Check Dictionary & Resources” button, then select the settings and add the “User Hints” option to your list. You’ll then be able to access it from the dropdown menu.

Thanks for your feedback on the Library! One thing to keep in mind is that everyone uses the site slightly differently, or would like to use the site in a specific way, but these are not all possible so we often have to settle on a middle ground. When you archive a lesson, it should disappear from the list within a few seconds. If not, refreshing the page should help. Are you finding certain lessons to stay there regardless of how many times you try and archive them?

We’re more than happy to continue working on the roses on the Lesson page to encourage more users to give roses when they like certain lessons.

There isn’t yet the functionality to show patterns. This is something that we would like to do, but much of it would need to be done manually on a lesson-by-lesson basis, so it will end up being quite a bit of work. We don’t want to just do it half way, so instead we’ve got it on the back burner and will try to get to this some time in the near future.

I’m using Chrome I was just reviewing Who is She and I tried to turn a phrase into a linq and, but no such luck. Got frustrated and left the page.

edit: I just hit the enter button to make a new paragraph and my message got posted. How long before this new version of Lingq becomes stable? Thanks for your help Alex.

double edit: the editing window is really tiny, making it ‘uncomfortable’ to edit posts. The box is three lines thick, but a post might be 25 lines. Like viewing a post through a slit.

triple edit: The edit box is now normal. Wow, this site is glitchy! I just was going over a new lesson and the enter button for creating lingQs was working perfectly! Until it wasn’t. Halfway through, it just stopped working. The “k” button doesn’t work at all. The arrow button does allow me to scroll between blue and yellow words without issue.

That seems strange. What browser and os are you using?

I also noticed sporadic malfunction of the shortcut keys, usually after creating a dictionary entry which consists of two or more lines (e.g. one line in English and one line in German). I just hit F5 to reload window, but it is definitely some kind of a bug.

And “replay to post” window IS only 3 lines which make writing posts longer than 3 lines inconvenient.

And when when the lesson is re-opened (with QuickLinQ turned off), the focus (dictionary) is on the last read word, but the window shows start of the lesson, you need to scroll to the place where you left.

Using Chrome @Win7.

Same as me. Chrome and Windows 7. Pretty standard set up.

edit: it appears that when you reply (as I just did) there is no “post” button. You have to hit Enter to post the message, which means making paragraphs is impossible. But if you edit a message, then the enter button works as normal. But this is because a “save” button now shows up.

That is strange. If you can reproduce it and let us know how we can do so ourselves, that would be great.We will try and see if we can do so as well.

Regarding your last point, if QuickLingQ mode is OFF, the page will not scroll to the currently selected word. If you want that functionality, you need QuickLingQ mode ON.

Does Shift+Enter allow you to enter a new line? It should do.

Can you tell us which phrase you are trying to LingQ that is not working? In which lesson? We can’t seem to reproduce this issue.
Also, which view, minimized or maximized, are you in when your k button doesn’t work? There is an issue in minimized view with the k and x keyboard shortcuts.

It’s not just one phrase. It’s about every, I don’t know, 10 lingQs, number 11 freezes up. I then have to go to another word and come back to it, and then it will work. On occasion, it all has jammed up. Sometimes a window won’t auto disappear and I have to click the X button to manually close it (when you hover over a word to get the definition). It’s probably the combination of all the bugs that is having unintended consequences. As for minimized or maximized, If I’m understanding this correctly, I maximize the screen by getting rid of the words on the right by using the little arrow button. In that mode, the K button is useless, as is the X. I find I quite often have to pound my enter key to create a lingq. Sometimes a soft touch works, other times not. Other times it requires a pounding (a good solid hit). And sometimes, I have to move on to another word and come back in order to make that linq. This is especially true for making phrases.

Thanks for the additional information on this! Would you be able to check the error console (Using The Browser Error Console - Garden Gnome) when this happens again and let us know if there are any errors showing when the “K” or “X” button stop working?

The K button was working fine, as was the Lingq Enter button. And then it stopped working. After hitting the K button and Enter buttons several times, here are the notes from Javaconsole.

===> event: popover:action, State: M=ready, D=minimized, R=min_selected_term, Popover=active, HS=inactive, PC=active e78efcd342cb.js:374
markCardKnown inactive e78efcd342cb.js:178
===> event: navigation:known, State: M=ready, D=minimized, R=min_selected_term, Popover=active, HS=inactive, PC=active e78efcd342cb.js:374
highlightPhrase e78efcd342cb.js:234
HS.onNavigationConfirm inactive e78efcd342cb.js:125
v.Event {originalEvent: KeyboardEvent, type: “keydown”, isDefaultPrevented: function, timeStamp: 1407403590036, jQuery18307931470177136362: true…}
false false e78efcd342cb.js:177
===> event: navigation:confirm, State: M=ready, D=minimized, R=min_selected_term, Popover=active, HS=inactive, PC=active e78efcd342cb.js:374
s {_transitions: Object, _states: Object, _events: Object, currentState: “inactive”, startStateMachine: function…}
closePopover active undefined e78efcd342cb.js:111
===> event: popover:action, State: M=ready, D=minimized, R=min_selected_term, Popover=active, HS=inactive, PC=active e78efcd342cb.js:374
markCardKnown inactive e78efcd342cb.js:178
===> event: navigation:known, State: M=ready, D=minimized, R=min_selected_term, Popover=active, HS=inactive, PC=active

Great, thanks! I’ll let you know if we need any additional information to get this one figured out!

Found when the shortcut keys stop working.

If you click on the yellow word and change the language flag for dictionary entry all shortcut keys stop to work.

(Chrome, Win 7)

Thanks, we’ll look at getting this fixed!

Bug - If you select expression (highlight more than a one word in blue) and press “k” page will crash. And page can’t be reloaded.

Chrome, Win7

I haven’t been able to reproduce this one yet. Would you be able to record a screencast and send it over? You can use something like Jing (Screen Capture Software | Snagit | TechSmith) to do this. Also, a screenshot of the error console would be helpful!

No audio, but I’ll comment - I select two words, press “k” on the keyboard and page hangs. Than I click on “Refresh” (F5 doesn’t work), and after ~2 minutes page reloads (with Internal Server Error 500 in console).

Thanks for the screencast. I see, in fact it shows the same error in the console for me (since you can’t mark a phrase as known, hence why the button doesn’t appear on the blue popup). However, it doesn’t hang at all - the server responds within a second or two with the error, and everything happens in the background.

I think this may be a networking issue causing the error response to be delayed. If this is just happening for phrases then I might hold off on adding it to our list, since this isn’t a supported feature (i.e. marking phrases as known). Is this happening for regular blue words as well?