Problems with cloze test

Even though I’ve created around 50 LingQs and the flashcards work perfectly fine, when I try to use the cloze test in English I get the following error message: ‘No LingQs to cloze test’.
I also have problems with this function in Japanese and Chinese. It works, but it doesn’t include all the terms I’ve LingQed.
Could you please try to look into this problem or tell me if there’s a special way to configure the cloze test?

Thank you

@lawliete - which LingQs are you trying to close test? Are they in a lesson or are you trying to access the cloze test from the vocabulary page? In either case, it should be working fine. If you can provide more details about what you are trying to do, it will help us track down the issue.

I always use the cloze test from the vocabulary page. Actually, the LingQs that don’t work are the ones I’ve added manually (they weren’t in any lesson).I thought if I used the cloze test on those LingQs I’d be shown the Phrases in them without the terms I’m studying. But maybe the cloze test only works with items in the lessons. If that’s the case, then everything’s working properly.

The Cloze test only takes phrases from lessons in your My Lessons lists. Therefore, if you don’t have any lessons containing that term, which is likely for the terms you added manually, then the cloze test won’t work for those terms.

Although LingQ allows you to LingQ words manually, there is a lot to be said for creating LingQs from lessons. Cloze tests and examples of useagework better with words taken from lessons.

Remember you can add your own lessons with extracts from web pages, ebooks, Word Documents etc.

@mark- Thanks! That makes it clear how it works.

@skyblueteapot- Aside from studying Chinese and Japanese, I only use LingQ to study new words I come across while reading books, so I’ve never thought of adding lessons. But it seems a good idea to include some passages from books in My Lessons list. Thanks!

I’ve recognized that my daughter picks up new words better from meaningful content than from word lists.
Yesterday I’ve made the first cloze test with her and it worked pretty well. She liked it.

I am new here, but I’ve only worked with lessons, not with own word lists, and I have the same problem - No LingQs to cloze test! I selected all, I selected some of them - nothing. I thought first it was because of my status - now I am “basic” - it didn’t help. Then I thought it doesn’t work for the Beta Languages - but Russian is supported, and nevertheless - no cloze test.

Czech is the only language where it works, and even before upgrading to “Basic” (though the first time I tried to follow the link from my daily e-mail there was the same problem, no LingQs to cloze test.) But starting from the vocabulary page it worked fine.

But when I tried with Polish, Norwegian and Russian - always the same thing - nothing to test.

I have no idea why, but now it works in all the languages! :slight_smile:

If you did something to solve the problem, thank you very much! If not, technology can be mysterious…

Well, glad to see it’s working properly for you! If you come across any other problems, please let us know. :slight_smile:

Actually I’m having a problem with Cloze test not working. If I go to “Edit LingQs”, I see a bit more than one page of LingQs. I then go to a lesson (Clicking on “My Lessons” then selecting one). On the far right side I click on “Cloze” in the “My LingQs” box. I then get the message “No LingQs to test”! I’m trying German. (And I’m very new here, so if this is an obvious question, my apologies!).

What am I doing wrong?

Thanks much.

How many LingQs appear in this particular lesson? Can you try the Flashcards button as well to see how many appear?

I see 17 LingQs in this lesson. The Flashcards button brings up flashcards and lets me go through them as I expect. (I don’t see all the LingQs in the flashcards, but I’ve gone through the deck a few times and I guess it removes words as you catch on). I’m not sure what the “Cloze Test” does - maybe I don’t need it??

@rrlear - The cloze test will only work for LingQs that have been created out of sentences in the system. Did you import those LingQs or is the text you LingQed them from lacking in complete sentences? Could you send a screenshot of your lesson with your My LingQs list showing so we can try and figure out what is going wrong for you? Just email the screenshot to support [at] lingq [dot] com.