Problemo with bookmarklet and iLingQ app

So the days of me posting endless threads identifying problems with the software might have seemed like they were in the distance past, but I am back and working hard on LingQ to learn German and Russian. I have identified a problem with using the iLingQ app with content that has been imported with the bookmarklet. It seems that when importing something with the bookmarklet, links on the website that are embedded in the text are not totally removed and this information then filters into the app. For example, I imported this text

Notice that “„tagelangen Blackouts” und Gedächtnisverlust" is a link to another webpage. When I then tried to press the word ‘tagelangen’ when reading this in the app, everything got messed up because it still is recognised as a link. On the browser interface, this is not the case. The way to fix this is to then open the edit lesson page and click ‘Save’. This then removes the links. It would be great to have this fixed such that either the links are removed automatically when importing the content, or the app just ignores the links.

Also, there is a problem that lesson titles must not be more than 80 characters, but when importing a lesson with the bookmarklet, the titles are longer. This means that when I open the lesson in the edit lesson page and try to save it, I have to manually truncate the title.

I’m having problems as well. I just tried to use the chrome extension and it doesn’t work. When I try to lingq on the page, nothing happens. And when I try to open things in a new page, i get an internal error message.

Sorry about that and thanks for letting us know about this. I’ll report this to our development team and hopefully they will find way to fix this soon.

Hi again,
we are not able to reproduce this issue with import bookmarklet links within a lesson. It would be really helpful if you can send us screenshots on our Support Email. Would you be able to do that? Thanks!

Ok, so here is what I did. I went to a newspaper article in German and found an artcle that contains a link in the text (the almost always contain several). Here is the one I found

The link embedded in the text is in the words “Der Standard meldet”, as can be seen here

I then select the paragraph and import it into LingQ using the bookmarklet

On the browser interface, everything looks and is fine. When I then open the lesson in the app on my iPad, the lesson also looks fine

However, when I then press on “Der Standard meldet”, which is where the link was embedding in the text on the newspaper website, it loads a website quickly and then the lesson reappears but with all the text missing.

Just to be clear, the website that got loaded in this case is not the original website that I imported the content from (though the subject of the article is the same). If I reload the lesson, it is back to normal, but the problem is still there. The problem is also present when I use the app on the iPhone.

I can fix this lesson simply by opening the Edit Lesson page and then saving it again. It seems at that point, the original link embedded in the text is removed, but it is not removed when importing content using the bookmarklet alone. The fact that I need to open the Edit Lesson page (and then manually truncate the title) kind of ruins the convenience of the bookmarklet since in reality what I want to do is just quickly import a few news articles and then quitely sit back on a comfortable seat and read them on the iPad.

Hello Everyone - The IOS App should now be working perfectly well, as it has been upgraded in Itunes. If you’re still experiencing issues please let us know.

Thanks for your patience :slight_smile: