Problem with the "new" forums

Previously, on the old format, I was able to right click on the forum post and right click “Open link in new tab”, so it made sorting the threads/reading them easier. Now that function is not possible. I’ve tried on both Chrome and Firefox. I think this is the first time I’ve been disappointed with an update on LingQ, but I hope it gets resolved and hope this problem will be resolved soon because as of now, browsing the forums takes a lot longer because of not being able to open threads in other tabs while having the main one in one tab.


Yup. Totally agree. Glad I wasn’t the only one that found this frustrating. Not not should every link in the world be able to open like that, it’s particularly important for the forum, so you can scroll through quickly, pick out your threads to read, and then comment all in one shot.

In addition, I can’t seem to be able to see who has liked/given roses to my comments. I just see the number and clicking on it yields nothing.


I can’t even scroll down on Kindle. Are you able to do that?

The main Recent Threads list can’t do this anymore I’m afraid because of the way it is built but we will be returning the active threads list to the sidebar once you open a forum thread. From there you will be able to right click and open links in other tabs again. We will try to add back the ability to see who has liked your post although you should see this information in your notifications list as well.

1 Like

It’s very frustrating indeed.


It became much more difficult.
For what reason?
What was wrong in a former version.?..


Good question. People like to change things, maybe to show they’re really working.

1 Like

I was thinking yesterday about how Windows 95 was an improvement to Windows 3.1 while Windows 8 was just a whole lot of annoying changes which ruined everything. I don’t want to be all negative and criticise everything but this change to LingQ really is not an improvement. Maybe it’s just an indication that the human drive for progress is really completely irrational as opposed to rational so that things have to change even if it means changing something that’s already working fine and then ruining it. I don’t know if I’m just getting old and therefore tend to bitch more about changes or if bad changes occur more often nowadays. As far as I’m concerned civilization reached its peak around the time of Windows XP – in 2002. Fasten your seatbelts because it’s all downhill from here!

We have added the recent threads list back again in the sidebar. We will continue improving things over time here…

1 Like

Not a ‘progressive’. Blessed are you.

Enjoy the decline!

Check out the audiobook fragment

I have added this to my kindle wishlist.

Wow. I can’t edit my post. I meant “amazon wishlist”.

It seems strange you can’t edit. What browser are you in?

It says Firefox Quantum 61.0.1 (64-bit). I checked again to make sure I didn’t press cancel instead of save but it really doesn’t work. I also tried re-entering the thread and then clicking reload in the browser.

That’s strange. Editing seems to be working on Firefox. Are you on Windows?

Windows 10 64 bit.