Problem pasting text when editing lessons

[I originally posted this in the Open Forum, but I think it should have gone here instead, so re-posting it now]

I’m spotting a few typos as I’m going through the Bulgarian mini-stories, and I find that when I go into the ‘edit lesson’ screen, although I can type new text (which doesn’t help me since my keyboard is not in Cyrillic), and delete existing text, I can’t paste anything, whether I try to do it with the ctrl+v shortcut, the mouse menu or the edit menu in my browser This seems to be true of both Firefox and Safari on my MacBook, and also of Firefox on my Windows PC.

Does anyone else have this problem, and can it be fixed?

Strange, I tried on my end on Chrome and Firefox and I can copy-paste on the Edit lesson page without any problem. I can’t reproduce that problem. What exactly happen when you try to paste? Do you get any error message?

No, no error messages or anything; it’s just that nothing happens when I right-click and paste, or when I type ctrl+v.

I have the same issue with pasting text, when editing Traditional Chinese. Pasting does not work.

Strange, I am still unable to reproduce the issue you guys mentioned. @PGK are you also using Firefox browser?

I’m using the latest Chrome browser, with Windows 8.1.

So, I’ve found a workaround by figuring out how to get my laptop to type in cyrillic. The pasting problem persists, but it’s not an issue for me any more :slight_smile:

1 Like

It seems that Paste does not work if you enable Show/Hide Sentences. Without this it works fine (Safari 12.1.1)

I’m not sure where the show/hide sentences option is. It’s mostly not a problem, but there are some places where one of the translators has written й instead of ѝ, and I can’t find the ѝ option on my keyboard, so I need to be able to copy and paste that if I can’t figure out how to type it.

So, as suggested in my earlier comment, my workaround of typing with the Cyrillic keyboard on my macbook doesn’t work when it comes to the letter ѝ - that is, the accented version of the normal letter и which distingueshes the feminine short possessive pronoun from the word for ‘and’. And after asking people on Reddit, and having a look at the Wikipedia article on keyboard layouts, it looks like the version of the Bulgarian keyboard on my laptop may simply not even have that accented letter ѝ. How that happened I don’t know, but if true, I will still need to be able to figure out how to paste text in the LingQ lesson editor.

@musicserver77 , you said something about paste working or not depending on whether you have ‘Show/hide sentences’ active, but I have no idea where the show/hide sentences option is. It doesn’t seem to be on the edit lesson page. Where should I be looking?

Directly under “Add URL” there is a shaded box, with border, “Show/Hide Sentences.”

When I’ve had pasting problems in the past they seem to have been related to this. Also, when copying from pdf of Peace Corps books I’ve first pasted into Word using “paste special-text,” seems to work better.

Have you shared any Bulgarian materials? So far I see only the Mini Stories and the few things that I’ve shared.

That option comes up in the page for adding a lesson, but not in the page for editing an existing lesson, as far as I can tell. Does it work like that for you?

Also, no, not yet, sorry. I do have some English materials which I’m wanting to get translated into Bulgarian, and I’m still waiting for approval to join a Bulgarian freelancers’ facebook group where a friend suggested I should be able to find translators, but haven’t heard back yet. I might try putting a request up on Reddit; the Bulgaria forum ought to contain some people willing to have a go.

Ah, I see now, editing an existing lesson is indeed different from importing from scratch.

Good luck with the translation activities, and thanks for doing that.