Problem importing .csv vocabulary file

I am trying to import a Korean vocabulary using a .csv file but get the following message:

Incorrect file format: missed “term” or “phrase” column.

In an effort to clarify the problem I resorted to trying to import a single line .csv file created in Google Sheets and saved using “File>Download>Comma-separated values (.csv)”

The resulting .csv file contains only the following line.

한국, 한국 사람이에요, tag1, tag2, en, meaning1, en, meaning2

The error still persists.

A couple of further comments:

  1. When opened in a text reader this file is found to be in UTF-8 format.
  2. I have tried a few various combinations like removing spaces after commas, removing elements like “tag1” whilst leaving the commas. This does not resolve the issue.

Any help/advice appreciated. Thank you.

Can you please send your file to support@lingq.com? I’ll take a look. Thanks.

1 Like

Thanks Zoran, but I believe I have resolved the issue.

The problem was omitting the column headings.

I discovered this by exporting my LingQs in .csv format and using the resulting file as a template (sorry that I only thought to do this after posting my query).

Once I included the proper column headings (“term”, “phrase”, etc.) it all worked.

I have since successfully uploaded a couple of vocabulary files so I have the hang of it now.

Thank you anyway for taking the time to respond.

1 Like

Great, glad to hear you figured it out!