Playlists in the new app have stopped working

As of yesterday, I can no longer load my playlists in the new app. When I try to access any of them, I see a long list of lessons with blank icons and blank titles and the word “Waiting” next to each. However, no amount of waiting seems to work. If I press the play button at the bottom of the list, the app crashes.

It was working perfectly before.

@solanderdog - sorry to hear about that! Would you give a bit more detail so that we can track and reproduce the issue? How do you add lessons to playlists? Do you delete some of them? How long is your list if lessons in playlists? If you describe you behavior in the app more specifically, it will be very helpful for us to understand where the issue is. Thanks!

No problem.

I add lessons to my playlists by selecting a course and swiping on the various lessons within it to reveal the “Add to Playlist” option. There is another way?

I do delete lessons from my playlists from time to time, but I haven’t done that a lot with the new app. I think I may have deleted one lesson from one playlist so far since upgrading.

Currently, I have five playlists which have 17, 19, 8, 2 and 3 lessons in them.

I just tried adding some random lessons to these existing playlists and that seems to have made two of them work. I can now see all of the lessons in two of my five playlists, the old lessons from before and the ones I’ve just added. In the remaining three playlists, I see only the icons and titles of the lessons that I’ve just added. All the other lessons still lack icons and titles. If I click on one of these ‘invisible’ lessons, the app tells me it is loading a lesson, but I only get an empty lesson page when it finishes.

I now have all five working.

@solanderdog - Well, glad to hear you got it working properly! We’re still not quite sure what would have triggered this, so if you encounter this issue again please let us know what you think might be causing it. In the meantime we’ll keep our eyes open and see if we can reproduce this.

Thanks. Will do!

I was having this problem again with nearly all of my playlists this morning. In the process of restoring them, I realized that I didn’t have to add new lessons to my playlists in order to bring them back. I was able to get them working again by opening the course that the lessons were originally taken from, in the main list of courses, and refreshing it. I think what might be happening is that when a course gets bumped out of memory by another course, the lessons from the first course are no longer available in one’s playlists, and selecting a playlist doesn’t seem to load these lessons on its own.

I have just noticed this problem today. I was listening to my playlist in the car, when the app crashed (that one is an old bug that I’ve reported before). So I reloaded the app, went straight to the playlist and saw all the lessons were grey with the word “waiting” next to them. Pulling down the playlist to refresh made no difference.

However later on I noticed that if I went into one of the courses first, the lessons from that course got loaded and then appeared in the playlist. I went into a second course, and that loaded the remaing lessons in my playlist.

It would appear that if a lesson in a playlist is forgotten for any reason, the only way to reload it is via the course screen and not the playlist screen. This seems to match what solanderdog has described.

@solanderdog, neofight78 - Thanks! I’ll let you guys know if we need any other information while trying to get this one figured out!

I updated to 3.0.3 yesterday and this problem remains.

@solanderdog - sorry about that… Don’t you see your playlists at all or can’t make them play?