Playlist not downloading completely (Android)

I’ve been having problems downloading my playlist on the Android app. This happens both in my “custom” playlist and the playlist for different courses.

The first 4-6 tracks will download, but the rest will not. They still have the little download circle but aren’t loading.

I have tried clearing my cache and toggling between allowing downloads on 3G or not, but it doesn’t seem to make a difference.

When I try to listen to the playlist, the player will continue to highlight the next track down as if they are all playing but the audio is just repeating the last downloaded track over and over again.


Sorry to hear that. What happens if you tap on the track? Does it download and play in that case?

Ok, I’ve tried several times and here are the patterns I’m seeing:
------------------ Trial 1: Start listening to something first, then try to download a new track

  • Open app, click on playlist tab.
  • Start playing any track that is already downloaded.
  • Click on a track that is not downloaded yet.
  • Result: the first (already downloaded) track just keeps playing, even though the “new” (not yet downloaded) track is highlighted. Player seems unresponsive or unable to switch to the new track, it just keeps repeating the first one you click on and the new track won’t download, even though it is highlighted as if it were playing.
    ------------------ Trial 2: Start listening to a new track first
  • Open app, click on playlist tab.
  • Click on a “new” (not downloaded yet) track.
  • The track downloads and begins playing after download is complete.
  • Click on a different undownloaded track.
  • Result: the next track does not download, the player just keeps repeating the first one that is clicked on. Just like in Trial 1, the new track is highlighted like it is playing but the audio is just a loop of whatever track you clicked first.
    ------------------ Trial 3: Let the player “run into” the undownloaded track
  • Open app, click on playlist tab.
  • Start playing the playlist (the first 5 tracks were already downloaded)
  • Let the player keep playing until it comes to the undownloaded track.
  • Result: The “new” track won’t download, the player just keeps repeating the track before it.

So it seems I can get the tracks to download, but only one at a time and only if I don’t play something else first. Then I have to force-close the app to stop the player just looping on the first track I clicked (no, I don’t have the repeat button on, haha!). Once I get them all downloaded, I can let the playlist run from top-to-bottom like normal but as soon as the player hits an undownloaded track, it just keeps repeating the last played track.

Hope that little bit of investigation helps!


Wow, that’s detailed! Thanks for providing all of that information because I am having the same issues.

Thanks for this. I’ll forward to our Android developers.


Hi all, android user here and I’m still having the same issue as that listed above. Any updates on this would be great, thanks.

Will be taken care of in the upcoming update…


Does anyone know when the upcoming update to the Android app will arrive? Seems rather important to get the playlist function fixed.

Beta should be released in a few days and shortly after hopefully version for all users.


The problem is still persisting for me. I’m in beta and using the latest app update. I was still having playlist problems so I tried clearing my cache and I’m still getting the same results as originally posted. The first track downloaded correctly, but then it just kept looping that track and wouldn’t play anything else until I force-closed the app and chose a different track. Then repeat the same thing. Doesn’t seem like anything has changed.

I had the same problem when newly use LingQ. I found out it’s just because some lessons were downloaded while using wifi then at home, I try to play them with 3G… (???). My solution is to refresh the playlist, each lesson with the circle would be downloaded steadily.

*The command to refresh might vary on different phones. I do this by swiping the screen downward.

Android 5.0 beta wasn’t released yet. Current production version and beta version are exactly the same.
5.0 beta on Android will be released in few days.

FYI I’ve been checking on this problem every so often and it has never been resolved. I’m keeping my fingers crossed that the eventual 5.0 update does the trick because I basically gave up using the playlist feature through the android app.

I felt this was working for me with my Nokia phone, but after switching to another phone there have been problems. It seems to work better on wifi, so I only use the playlist when I’m at home.